Microsoft Edge doesn't load data when using Javascript API

1629
2
04-10-2018 07:27 AM
MollyFoley
Regular Contributor

The Javascript API 3.23 site says that it supports Microsoft Edge, but I cannot get any of my data to load in an edge browser. It only loads the basemap. In Chrome, my feature layers show up, in Edge, they do not. Anybody else encounter this problem? I get a couple error messages:

SCRIPT5: Access denied. 

SEC7117: Network request to https://xxx/rest/services/HbMonitoringTest/HabitatData/MapServer/2?f=json&callback=dojo_request_scri... did not succeed. This Internet Explorer instance does not have the following capabilities: privateNetworkClientServer

I'm not using any proxies or doing anything weird, it's a pretty simple set up:

var cipCentroidsFL = new FeatureLayer("https://xxx/rest/services/HbMonitoringTest/HabitatData/MapServer/0", {
      refreshInterval: 1440,
    });
    cipCentroidsFL.setMaxScale(1000000);
    cipCentroidsFL.setMinScale(20000000);
   
    var cipAreasFL = new FeatureLayer("https://xxx/rest/services/HbMonitoringTest/HabitatData/MapServer/3", {
      refreshInterval: 1440,
      infoTemplate: cipPopupBox,
      outFields: ["*"]
    });
    cipAreasFL.setMinScale(999999);
   
    var patchesFL = new FeatureLayer("https://xxx/rest/services/HbMonitoringTest/HabitatData/MapServer/1", {
      refreshInterval: 10,
      definitionExpression: 'EXTRACT(YEAR FROM "ObsvDate") = '+ currentYear,
      infoTemplate: patchesPopupBox,
      outFields: ["*"]
    });
    patchesFL.setMinScale(500000);
   
    var protectCoverFL = new FeatureLayer("https://xxx/rest/services/HbMonitoringTest/HabitatData/MapServer/2", {
      refreshInterval: 10,
      definitionExpression: 'EXTRACT(YEAR FROM "ObsvDate") = ' + currentYear,
      visible: false,
      infoTemplate: pcPopupBox,
      outFields: ["*"]
    });
    protectCoverFL.setMinScale(500000);

    patchesFL.setRenderer(qhRenderer);
    protectCoverFL.setRenderer(pcRenderer);
    cipAreasFL.setRenderer(cipRenderer);
    map.addLayers([cipAreasFL, cipCentroidsFL, patchesFL, protectCoverFL]);‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍
Tags (1)
0 Kudos
2 Replies
DanPatterson_Retired
MVP Esteemed Contributor

is it enabled?  from windows help

For Microsoft Edge, you can disable/enable Javascript from Windows Group Policy editor. Kindly follow the steps below:

1. Click on Start, type Edit group policy and select it.
2. Expand the User Configuration -> Administrative Templates -> Windows Components folder.
3. Expand the Microsoft Edge folder
4. Double-click allows you to run scripts, like Javascript.
5. Choose Disable and click OK to confirm.

0 Kudos
MollyFoley
Regular Contributor

Unfortunately I do not have that setting. 

I'm not clear why I would want to disable Javascript anyway? I think you meant "enable" in your last direction.

0 Kudos