Problems using Interpolate polygon to Multipatch

2340
1
06-13-2013 01:24 AM
DaveCapstick
New Contributor
Hi,
I have a problem when using the Interpolate polygon to Multipatch tool.  I have a TIN (10 x 10 km) and several polygon vector datasets representing topography in a file geodatabase. (For those that are familiar with UK Ordnance Survey data it is the OS Mastermap Topo areas).  I would like each of my polygon datasets to be integrated with the TIN model using the interpolate polygon to multipatch tool.  Using one polygon dataset it seems to work fine.  A second polygon dataset is always crashing out of the process with the following error :-

ERROR 999999: error executing function
TIN internal process error
Failed to execute (InterpolatePolyToPatch)

Does anyone have any idea what the problem is? If it's the TIN, it seems odd that it works for one polygon dataset and not another.  I don't think it's related to the size of the datasets, since the one that works is larger than the one that doesn't work.

Thanks

Dave
0 Kudos
1 Reply
Tim_Ultee
New Contributor III

I just got the same error trying to create a multipatch from a utilities polygons feature class using an elevation TIN file I just created from a raster. I tried creating the multipatch inside and outside of a file geodatabase but got the same error. The multipatch is actually created despite the error, but is missing some features (~200 of 12,000). I don't see any rhyme or reason to why some weren't converted while others were.

multipatch feature‌ #arcgispro 2.2

0 Kudos