3D Basemaps Solution - Error with extracting vegetation

07-20-2020 07:04 AM
Esri Contributor


I'm working with an LAS Dataset and am attempting to extract the vegetation from it for visualization in a scene in ArcGIS Pro 2.5.2.  Vegetation is classified with codes 3, 4 and 5 in the LAS data.  The task for extracting the vegetation in the solution is generating an error, however, regarding an invalid rule package -- here's the full text of the messages generated by the script:

Running script Extract Vegetation...
Project Home Directory is: D:\VegetationLeichlingen
Executing set_up_logging...
Logging set up.  Log location: D:\VegetationLeichlingen\Logs
Coordinate system: ETRS_1989_UTM_Zone_32N
Coordinate system type: Projected.
No Vertical coordinate system detected.
Coordinate system: ETRS_1989_UTM_Zone_32N
Coordinate system type: Projected.
No Vertical coordinate system detected.
VegLASD Layer Complete
ptSpacing is 0.0
Raster Pixel Spacing is 1.5
LasPointStatsAsRaster Complete
Create Slope Raster and remove all vegetation less than Min Veg Height Complete
Primary Filter Complete
SecondaryFilter Complete
FocalStats Complete
negate Surface Raster Complete
Vegetation Direction Raster Complete
Vegetation Sink Raster Complete
Vegetation Polygons Complete
Vegetation Points Complete
D:\Data TRLE\5G Use Case\Leichlingen\Daten Leichlingen.gdb\Gebauede_Footprints
Begin Attribution of Vegetation with Info
negate Surface Raster Complete
Con negate Surface Raster Complete
Con negate Surface Raster Classified Complete
Veg Flow Direction Raster Complete
Veg Flow Accumulation Raster Complete
Calculating BASEELEV...
Calculating Tree Heights...
Creating 3D buffered vegetation points: D:\VegetationLeichlingen\veg\veg.gdb\veg_3D
Failed to execute. Parameters are not valid.ERROR 001557: Invalid rule package. Failed to execute (FeaturesFromCityEngineRules).
Error on line 601
Error in file name:  D:\Data TRLE\3D Basemaps Solution\3Dbasemaps_8ee4ba\p20\scripts\bm_common_lib.py
with error message:  AttributeError: Object: Error in parsing arguments for Exists
Completed script Extract Vegetation...
Failed to execute (VegetationExtraction).

Any assistance would be greatly appreciated.  Thanks!

0 Kudos
3 Replies
Occasional Contributor

I received the same error so I went to the solution download directory (C:\Users\myname\Documents\ArcGIS\Packages\3Dbasemaps_8ee4ba\p20\rule_packages) and applied the ThematicTrees.rpk file. The symbolization worked, but no matter what units I choose, my trees are floating above ground.

0 Kudos
Occasional Contributor

Silly mistake. I had to set the trees feature class elevation to absolute height with the BASEELEV field from the tool to fix the problem. Once I converted the trees feature class to multipatch and applied the rule package (as the 3D solution task is supposed to do) the multipatch trees are correct from the beginning using absolute height and Geometry Z-values. I'm working with ESRI Tech Support on the error in the task.

0 Kudos
by Anonymous User
Not applicable

Hello im getting this error in the 3d basemaps solution. do you know how to fix it?

Error on line 201
Error in file name: C:\3DBasemaps\scripts\bm_common_lib.py
With error message:
ArcPy Error Message: Failed to execute. Parameters are not valid.
ERROR 000837: The workspace is not the correct workspace type.
Failed to execute (CreateMosaicDataset).
Error creating footprint raster.
Failed to execute (CreateDraftFootprintRaster).

0 Kudos