AnsweredAssumed Answered

Survey123 & Integromat with Portal for ArcGIS: "[500] Error performing queryAttachments operation"

Question asked by tcrowder on Jul 30, 2019
Latest reply on Aug 13, 2019 by tcrowder

I am stuck. I followed the steps in this awesome blog post for creating a connection to an ArcGIS Enterprise instance by Ismael Chivite : https://community.esri.com/groups/survey123/blog/2019/06/04/survey123-tricks-of-the-trade-integromat 

 

My new enterprise connection can see all my surveys in MY portal (this connector only sees surveys owned by the account you use to configure your enterprise connection from what I can tell). My newly configured webhook was automatically added to my survey, I test run the scenario, and then, bummer, I receive this error on every survey I have tried. can't queryAttachements error

 

We are on duel machine deployment of Portal for ArcGIS 10.7.1 with a federated server. The feature services are "hosted" in our data store and there are no issues with the survey functionality at all. It seems like the 1st step of creating the json payload from the webhook in my Integromat scenario is failing to capture the data. I get the exact same error even with a simple form with no attachment or geopoint questions. I've set sharing to public on all the services and forms. I've turned off server firewalls but the error persists. From my experience this seems like a permissions issue on the service, but I can't seem to figure out a solution. Any insight would be greatly appreciated! :-) .... James? James Tedrick  

Outcomes