AnsweredAssumed Answered

Connection to callback URL '[serivces url]' failed

Question asked by iamlaksh3 on Aug 10, 2015

Hi, I am facing an technical issue on ArcGIS server 10.3.1 in Windows 2008 R2. ArcGIS server protocol configured with HTTP and HTTPS and Web adaptor authentication ArcGIS server service running using my local administrator account. Problem: I am unable to publish the service and Publishing Tools are failed. SEVERE Jul 29, 2015, 3:53:42 PM AGSAdminConnect FAILED. System/PublishingTools.GPServer SEVERE Jul 29, 2015, 3:53:42 PM Error executing tool. PublishServiceDefinition Job ID: jd4742fe516364a0c9800d10344dc2cb4 : ERROR 001359: Failed to connect to the server. Failed to execute (Publish Service Definition). System/PublishingTools.GPServer My issue is similar to one defined in I have tried below steps a) Creating new self-signed certificate – does not work b) Reinstalled ArcGIS server – Does not work c) Recreated a site after commenting all entries in host file – now machine name (FQDN) is used in arcgis REST. d) Tried reconfiguring ArcGIS server using –admin account – Publishing tools worked fine in HTTPS e) Tried reconfiguring ArcGIS server using  -service account – Publishing DOES NOT WORK for https Summary: ArcGIS server does not work in HTTPS protocol on account other than local administrator account. I would like to know what exactly goes wrong when I use service account with HTTPS. How to fix this?