AnsweredAssumed Answered

Portal Creation: Index Service Configuration Failed

Question asked by hscspl1 on Sep 25, 2020

Hi,

 

I have just installed ArcGIS Portal 10.8.0 on Linux and I'm trying to create a Portal. However, everytime I try to create the Portal it fails with an index service configuration error message.

 

 

Prior to installation, I completed all of the prerequisites so all tests were passed by the diagnostics tool.

 

I have encountered the exact same error message when using the Enterprise Builder or by installing the Portal separately.

 

When I look at the logs, I see the following:

 

<Msg time="2020-09-24T14:14:42,403" type="WARNING" code="218015" source="Portal" process="54920" thread="1" methodName="" machine="HIDEMACHINENAME" user="" elapsed="" requestID="">Started Index Service.</Msg>
<Msg time="2020-09-24T14:15:42,923" type="WARNING" code="218014" source="Portal" process="54920" thread="1" methodName="" machine="HIDEMACHINENAME" user="" elapsed="" requestID="">Starting Index Service.</Msg>
<Msg time="2020-09-24T14:15:52,278" type="INFO" code="110905" source="Data Store" process="55085" thread="71" methodName="" machine="HIDEMACHINENAME" user="" elapsed="" requestID="">Failed to start spatiotemporal big data store machine. HTTP GET request failed. Connect to localhost:7220 [localhost/127.0.0.1] failed: Connection refused (Connection refused)</Msg>
<Msg time="2020-09-24T14:15:52,280" type="SEVERE" code="110902" source="Data Store" process="55085" thread="71" methodName="" machine="HIDEMACHINENAME" user="" elapsed="" requestID="">Failed to configure spatiotemporal big data store. Failed to start spatiotemporal big data store machine.
Caused by: HTTP GET request failed. Connect to localhost:7220 [localhost/127.0.0.1] failed: Connection refused (Connection refused)</Msg>
<Msg time="2020-09-24T14:15:52,281" type="SEVERE" code="218028" source="Portal Admin" process="55085" thread="1" methodName="" machine="HIDEMACHINENAME" user="" elapsed="" requestID="">Index Service configuration failed.</Msg>
<Msg time="2020-09-24T14:15:52,281" type="SEVERE" code="110303" source="Data Store" process="55085" thread="71" methodName="" machine="HIDEMACHINENAME" user="" elapsed="" requestID="">Attempt to configure data store failed. Failed to configure spatiotemporal big data store.
Caused by: Failed to start spatiotemporal big data store machine.
Caused by: HTTP GET request failed. Connect to localhost:7220 [localhost/127.0.0.1] failed: Connection refused (Connection refused)</Msg>
<Msg time="2020-09-24T14:15:52,281" type="SEVERE" code="218028" source="Portal Admin" process="55085" thread="1" methodName="" machine="HIDEMACHINENAME" user="" elapsed="" requestID="">Index Service configuration failed.</Msg>
<Msg time="2020-09-24T14:15:52,282" type="SEVERE" code="209024" source="Portal Admin" process="55085" thread="1" methodName="" machine="HIDEMACHINENAME" user="" elapsed="" requestID="">The process of creating a new site failed. Reverting site creation. Index Service configuration failed.</Msg>
<Msg time="2020-09-24T14:15:57,924" type="WARNING" code="218015" source="Portal" process="54920" thread="1" methodName="" machine="HIDEMACHINENAME" user="" elapsed="" requestID="">Started Index Service.</Msg>
<Msg time="2020-09-24T14:16:07,368" type="INFO" code="209074" source="Portal Admin" process="55085" thread="1" methodName="" machine="HIDEMACHINENAME" user="" elapsed="" requestID="">Connection file deleted from disk.</Msg>

 

Any help would be greatly appreciated.

 

Thank you

Outcomes