AnsweredAssumed Answered

Unable to load existing Web Apps from previous WAB dev versions with v2.2

Question asked by danielchantlos on Oct 19, 2016

I've been updating our WAB dev edition from v1.3 - 2.0 - 2.1 - 2.2 (most recent) at each release due to needed features associated with each release.

 

After the most recent dev edition update (2.2), I noticed that web apps built with any version besides the most recent version (2.1) will not load with 2.2. I was able to troubleshoot this by reverting to WAB dev 2.1, load all web apps needed for 2.2 dev version, and replace the .zip files on our server. Once the .zip files were replaced with 2.1 .zip files, I was then able to load these web apps for editing in 2.2 dev version. 

TLDR; web apps developed with any dev version besides the previously most recent dev version are not compatible with the newest dev version of WAB.

 

Has anyone else experienced this; or know of a more efficient troubleshooting process?

Outcomes