AnsweredAssumed Answered

Publishing MapService to ArcGIS Server problem (Slow and cannot publish data from SQLDatabase)

Question asked by abykov on Mar 28, 2016
Latest reply on Aug 24, 2017 by gbsgis

I am trying to publish a map to ArcGIS Server with one layer from SQL Server.

We have:

1. Data:

  • SQL Database with data
  • Most of Feature Classes are stored in Feature Sets

2. SQL Server (sqlsrv) with Data

3. Machine with ArcGIS Server agserver

  • This is a virtual machine
  • ArcGIS Server 10.3 installed
  • ArcGIS Server is running using domain account (agsacc)
  • agsacc account is an Administrator on agserver machine (Can access any folder)
  • Database (sqlsrv) is registered and verified (using Operational System Authentification)
  • I can see and use data from SQL sqlsrv in ArcMap on 'agserver' machine


  1. When I am trying to publish a shapefile (150kb)
    • Service published successfully, but takes 1-2 hrs to publish this service.
  2. When I am trying to publish anything from sqlsrv, it takes also about 2 hrs, but:
    • Publishing process failed with the error:

ERROR 001369: Failed to create the service. Failed to execute (Publish Service Definition). Failed at Thu Mar 24 18:46:18 2016 (Elapsed Time: 5 minutes 23 seconds) Failed. ERROR: the server's publishing job didn't succeed. Failed to execute (UploadServiceDefinition).

  • I can see in ArcGIS Server Manager that my service is "stopping"
  • When I am trying to stop it and run again, I have the following error:

Failed to construct instance of service 'test4.MapServer'. Can not open file C:\arcgisserver\directories\arcgissystem\arcgisinput\test4.MapServer\extracted\v101\ The system cannot find the path specified. Probable cause: The file is inaccessible to Server.

  • There is nothing (0 files) in this service folder


**What I have tried:**

-Set log level to Verbose (couldn't find anything). I am not sure what should I be looking for.

-Repaired ArcGIS Server Installation

-Reinstalled ArcGIS Server (still doesn't work)


**Update, 160328 1500**

    Just turned off Antivirus and shapefile published for a couple of seconds.

    However, map with data from sqlserver still cannot be published


    Got the following errors in the Log:

    -Core server call to create service failed.

    -Error executing tool.: ERROR 001369: Failed to create the service. Failed to execute (Publish Service Definition).

    -Failed to create the service.: ERROR: Service failed to start, Internal server error.

    -Failed to construct instance of service 'test20160328_2.MapServer'. Service startup timeout



Is there is a way to understand where is the problem?