AnsweredAssumed Answered

Getting exception: " Error code '400' : 'Unable to complete operation.'\Error executing tool.: ERROR 000816: The tool is not valid."

Question asked by mwinsor on Oct 6, 2015
Latest reply on Oct 9, 2015 by mwinsor

When I execute my geoprocessing processing tool, I get this error:

Error code '400' : 'Unable to complete operation.' Error executing tool.: ERROR 000816: The tool is not valid.

 

My package model includes the following tools:

  • Make Feature Layer
  • Make Table View
  • Make Route Event Layer

I've generated this package with ArcMap 10.3.1 and I'm consuming it with the 10.2.6 runtime.  According to the documentation that I've found, these tools are supported by this version of the runtime and this version of ArcMap.

 

Is this a problem in the runtime? In this version of ArcMap?

 

Is there a workaround for this?  I really need to generate a temporary layer and table view so the route event layer tool can execute properly. Working with this SDK is getting incredibly frustrating with its limitations.

Outcomes