AnsweredAssumed Answered

Add-In error with 10.3 and Visual Studio Express 2012

Question asked by dave_adams on Feb 6, 2015
Latest reply on May 10, 2017 by artifact

Hi,

 

am about to start migrating 10.2.2/VS 2010 Express addin code across to 10.3/2012 Express and I get an integration error when creating my first project. I installed studio first and then the SDK on top as per normal. The error is

 

error.png

When I investigate the log file the final entries are

<entry>

    <record>292</record>

    <time>2015/02/06 16:25:48.142</time>

    <type>Warning</type>

    <source>Microsoft Visual Studio Appid Stub</source>

    <description>CheckPackageSignature failed; invalid Package Load Key</description>

    <guid>{DDFC1641-E154-478A-AD20-CA65B07C8A6F}</guid>

  </entry>

  <entry>

    <record>293</record>

    <time>2015/02/06 16:25:48.142</time>

    <type>Warning</type>

    <source>VisualStudio</source>

    <description>Appid denied the loading of package</description>

    <guid>{DDFC1641-E154-478A-AD20-CA65B07C8A6F}</guid>

  </entry>

</activity>

 

Strangely following this the project did create and the first test button and toolbar worked ok in ArcMap. Has anyone else seen this error? I didn't want to invest too many hours migrating all my code and buttons to find I need to re-install Visual Studio?

 

Any suggestions greatly appreciated.

 

Dave

Outcomes