torbjornd

Updating hosted feature service

Discussion created by torbjornd on Feb 25, 2013
Hi.
I'm trying to update a hosted feature service containing polygons through a script/program. The script reads some information from an oracle database and creates a JSON describing the polygon features, which it then sends to the feature service (addFeature?f=json) through POST (System.Net.WebClient). The returning JSON (response) says the transaction is successfull, but when I refresh my ArcGIS Online Map, the new polygon does not show.

When opening the attribute table through ArcGIS Online, the attributes of the polygon shows correctly and the "zoom to feature" functionality works fine, but only the (selected) polygon outline displays (see attachment). I've been wondering if this problem could occur because of some unclosed polygons or geometry problems. I've tried to export the feature service to a shapefile, and when adding this shapefile to ArcGIS Desktop (or uploading once again to ArcGIS Online), the polygons shows up correctly.

Here is the JSON (of the polygon) recived by doing a query against the feature service:

{
      "attributes" : {
        "OBJECTID" : 3, 
        "VAOBJID" : 13250, 
        "VAARSAK" : "RE", 
        "VABESKR" : "SR", 
        "VABDATO" : null, 
        "VAPSTDATO" : 1361439000000, 
        "VAPSLDATO" : 1361455200000, 
        "VAVSTDATO" : 1361438940000, 
        "VAVSLDATO" : 1361440920000, 
        "VAPLANL" : null, 
        "VAVPOST" : 0, 
        "VAVDATO" : null
      }, 
      "geometry" : 
      {
        "rings" : 
        [
          [
            [597427.44, 6647123.94], 
            [597428.41, 6647113.94], 
            [597471.96, 6647113.32], 
            [597476.45, 6647085.55], 
            [597479.72, 6647033.27], 
            [597476.04, 6646958.12], 
            [597475.96, 6646908.94], 
            [597445, 6646909.5], 
            [597432.75, 6646876.44], 
            [597423.76, 6646876.44], 
            [597425.81, 6646910.33], 
            [597395.99, 6646915.64], 
            [597386.19, 6646960.57], 
            [597398.85, 6647075.75], 
            [597383.74, 6647073.7], 
            [597375.98, 6647090.86], 
            [597391.5, 6647096.58], 
            [597387.01, 6647117.81], 
            [597427.44, 6647123.94]
          ]
        ]
      }
    }


Does anyone know what might be wrong?

Attachments

Outcomes