Print widget not passing https through to new tab

567
7
Jump to solution
05-05-2017 01:14 PM
AmyRoust
Occasional Contributor III

I am getting so close to having my print templates working, but I am once again foiled by my organization's web proxy. I successfully repointed my print widget in WAB Developer edition to use the print service hosted on my server, and it generates the map from my internal templates. However, when I click to open the map, the s in https is not passing through and the user gets a "You do not have permission to view this directory or page" message. Can someone point me toward a solution? I assume I can just tweak something in the code.

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Amy,

   Can you not just have your IT people add the https url to the proxy rules?

View solution in original post

7 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Amy,

   Can you not just have your IT people add the https url to the proxy rules?

View solution in original post

AmyRoust
Occasional Contributor III

What directory needs to be added to the proxy rules? Must be the arcgisserver\directories folder?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Amy,

   Well it not really a directory. It would be the url that is giving you the https issue but be sure to be in-specific as possible when adding it. So when I use my print widget I get urls like:

ht tp://myserver/rest/directories/arcgisoutput/ExportWebMap_GPServer/_ags_610be093380548c49f04cec580a59186.pdf 

So the rule I would add would be ht tp://myserver/rest/directories/arcgisoutput/

0 Kudos
AmyRoust
Occasional Contributor III

Just got done meeting with IT to get a crash course in our reverse proxy setup. Long story short, the web server is https because it also hosts our web client for the county email system. However, when calls to our website hit the reverse proxy, the website is immediately converted to http. So, we have to enter https because that's what the server is expecting, but there is no certificate validation for our websites. We're just using the web server as a DMZ to protect the GIS server from attack.

I asked if we can convert the reverse proxy to https, and that's not an option. So ... is there a location in the widget code that I could hard-code the web link to https?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Amy,


  What reverse proxy are you using? I have been using an Apache reverse proxy for years and I can add a proxy rule that can be http or https without any issue.

0 Kudos
AmyRoust
Occasional Contributor III

We’re using IIS, but the entire frontend is configured for SSL. Even if we configure as http on the backend, the URL has to use HTTPS to get through the front end. The long-term plan has always been to move us off of the email server, but since it hasn’t been an issue until now, the project has been pushed in favor of more urgent issues.

0 Kudos
JeffPace
MVP Regular Contributor

Amy, 

 I recently had this exact same problem.  I solved it by making sure the path from end to end was https.

In my case, it was 

WAB to proxy on HTTPS

proxy to internal load balancer on HTTPS

load balancer to web adapter over HTTP (here was the problem)

web adapter to ArcGIS Server over HTTPS

Essentially, if http is anywhere in the chain, the protocol for the returned print page is HTTP.  It will only be https if the path is HTTPS all the way back to the hosted print service.