COGO finish error

401
5
Jump to solution
05-10-2012 05:25 AM
Labels (1)
Zeke
by
Regular Contributor III
I added COGO fields to a line feature class table in a file geodatabase in ArcCatalog, and then used the Traverse tool on the COGO toolbar to create a parcel. But whenever I do this, I get the error below when I click Finish on the COGO box. This happens with every parcel. If I delete the COGO fields, it works fine. Any ideas on how to fix this? I didn't find anything searching support. Thanks.

edit: I originally posted this under editing, but this seems a better forum. I can't delete the old post, though, so apologies if it seems like double posting. Not my intention.

[ATTACH=CONFIG]14233[/ATTACH]
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
MaudGillespie
Occasional Contributor
Have you checked the decimal places settings on the Units tab?  If this is more than 0, the software attempts to place decimals on the seconds and can easily over-run the size of the field. See the attached screenshot for the location of this setting.

View solution in original post

0 Kudos
5 Replies
MaudGillespie
Occasional Contributor
The error is associated with having COGO attribute fields that are not large enough to hold the values being produced by the COGO routines.  Did you add the fields yourself or did you use the Add COGO Fields function in ArcCatalog?  I would look at the length of the Direction Field and ensure it is at least 10 characters long (12 is preferred.)
0 Kudos
Zeke
by
Regular Contributor III
Thanks for the reply. I added them via the tool in ArcCatalog. I'm pretty sure the Direction field was 12 characters; I tried changing the length but can't do that on an existing field afaik. I did enter the direction in the format N 45.2367 E rather than N 45-23-67 E, but either way they should fit in field length 12. I can enter the segments, and they display properly, until I click Finish.
I didn't used to have this problem; maybe it's related to one of Arc 10's SPs?
0 Kudos
MaudGillespie
Occasional Contributor
Have you checked the decimal places settings on the Units tab?  If this is more than 0, the software attempts to place decimals on the seconds and can easily over-run the size of the field. See the attached screenshot for the location of this setting.

View solution in original post

0 Kudos
Zeke
by
Regular Contributor III
Thanks much, that appears to have fixed it. If I edit a cogo value in the attribute table, that doesn't actually change the feature , does it? It didn't when I tried it, but maybe missed something.
0 Kudos
MaudGillespie
Occasional Contributor
No, when using the standard editing tools (and not the Parcel Editor), editing the COGO value merely changes the value in the attribute field.
0 Kudos