Select to view content in your preferred language

Translate arcpy popup to Enterprise popup

986
7
Jump to solution
07-06-2023 01:36 PM
StephenRhea_NV5
Occasional Contributor

Is there a pre-built way to translate between arcpy CIMPopupInfo schema and Enterprise popup schema? Since publishing through Python doesn't maintain popups, I have to access the Portal item after publishing, build the popups, then call update() with the custom-build popup schema. The problem is that the CIM schema and Enterprise schema don't easily align, so I have to write some custom code to build the Enterprise popup. While it's fairly trivial, I'm experienced enough to know that some iteration of popup properties is likely to be overlooked. There's a good start on this Community post, but if an Esri-provided solution already exists, I'd love to use it. Alternatively, is there a page that defines the Enterprise popup schema? The only way I've found to access it so far is to get a Portal item and look through the get_data() return value.

0 Kudos
1 Solution

Accepted Solutions
JeffBarrette
Esri Regular Contributor
0 Kudos
7 Replies
StephenRhea_NV5
Occasional Contributor

@JeffBarrette @DannyMcVey Any advice? One of my biggest hangups is that similarly-named fields don't necessarily have the same schema, such as fieldDescriptions in CIM vs. fieldInfos in Enterprise, so I'm having to try every permutation I can think of in both environments, then comparing the results to map everything correctly.

Alternatively, any updates on the bug linked in the original post?

0 Kudos
JeffBarrette
Esri Regular Contributor

@StephenRhea_NV5 I don't have a suggestion.  I forwarded to the appropriate team.

 

Jeff

0 Kudos
StephenRhea_NV5
Occasional Contributor

Thanks, @JeffBarrette !

0 Kudos
JeffBarrette
Esri Regular Contributor
0 Kudos
StephenRhea_NV5
Occasional Contributor

Thanks for the link, and glad to see it's already in the product plan! Is there anything my clients and I can do to add extra weight to the bug to get it moved up in the backlog?

0 Kudos
JeffBarrette
Esri Regular Contributor

You could create a support issue and add yourself to the existing bug.

Jeff

0 Kudos
StephenRhea_NV5
Occasional Contributor

As a follow-on question, do you think this is inherently resolved by Enterprise 10.9 and 11.x including the ArcGIS Pro-based service runtime? I learned about that change over the weekend and figured it may be relevant, but I can't find any technical details on what's different.

0 Kudos