Newly split polygons not labeling

808
6
12-20-2016 05:49 AM
meganbarron
New Contributor II

I have been unable to find any other discussions that address quite this issue so far. My problem is that when I took a large polygon or two and split into many smaller polygons (a new subdivision), those new polygons have not labeled.

I have tried switching to Maplex engine and back. Yes the labels are turned on - all pre-existing polygons surrounding my work area are still labeled correctly.

Yes the expressions and settings for labels should be correct to my knowledge - this was set up before my time here and has never been an issue. I did check the expressions and they do include the right attributes. In this reasoning, other settings like scale ranges and label weights should not be an issue. NOTHING was recently changed.

I saw one person comment elsewhere that they recommended converting the labels to annotation and placing them manually but that is definitely not an option here; WAY too much data and too many labels and it would not work for our needs.

I looked into the Repair Geometry tool but read that it is redundant if I am using an SDE database, which I am. I reconcile and post my version daily so that should not be the issue. It has been a week now and my supervisor has pulled up the same data on his version and MXD and sees the lack of labels as well.

This is mind boggling to me, though I am certainly no expert. I should be seeing 2 forms of parcel ID, the lot numbers, and the area in 2 units. This is displayed without issue on other parcel polygons but ArcMap is not pleased with the new ones. Perhaps I have angered the beast.

My next effort will be to simply Save As a new MXD.

Update: this did nothing. I got a bit hopeful, though really I'm not surprised. It clearly isn't MXD specific since my supervisor had viewed the same issue from his computer/MXD/version.

I'm a wee bit concerned that it will be some sort of bizarre glitch in the data itself and that I'd need to redo the entire split. However this has been 2 full days' work and doing so would likely set me back another day.

0 Kudos
6 Replies
WilliamOstrander
New Contributor

Have you tried zooming in on just one of the new parcels?  If the labels are set to only display when they fit inside the polygon, it may be too much information to fit inside the new little parcels.  You've probably checked that out already, but just in case.

Bill Ostrander

Tioga County GIS

0 Kudos
DarrenWiens2
MVP Honored Contributor

Do the labels appear if you select "Never remove (place overlapping)" under Conflict Resolution in Placement Properties? Also, try viewing unplaced labels via the Labeling toolbar to get an idea if the labels are there and not displaying, or not there at all: 

meganbarron
New Contributor II

Sorry I haven't responded! No, the zoom/extent is not the issue as the surrounding polygons all label property. The issue is that I am not creating any sort of new situation - there are smaller, more crowded polygons that still display these labels even when zoomed out father. I have indeed viewed unplaced labels but nothing shows up for these polygons.

What is interesting is that it really is an occasional issue - I just now googled again today (and stumbled upon my own post which is disappointing) as it has happened again. No settings have been changed in any way. This is only the third time I've seen it happen - the second time it happened the subdivision was smaller and I simply delete the problem lots and used the 'Create Polygons' tool. Once I created fresh polygons there was no issue.

I'm about to do the same with this subdivision before I go any further; my first clue was when the block letters did not appear and now that I am putting in ID numbers for the lots the issue is definitely evident. The data is there in the attribute table, and this has truly stumped me.

Note: After the first subdivision where this happened, I have made likely a dozen or more other subdivisions, varying from 1 to about 80 lots and with lot sizes also varying, all without seeing this issue. It is not label properties, layer properties, etc from what I can tell. It seems to be oddly isolated, almost like a single hiccup. Thanks to all who read!

0 Kudos
MatthewDobson
Occasional Contributor

Megan, have you tried a repair geometry on the featureclass (see this)?? In my experience, polygons with geometry issues can display okay but fail to label.

Good luck!

0 Kudos
SamuelTroth2
Esri Contributor

Hi Megan,

Just to summarise; you have a polygon layer which displays the labels correctly. You start an edit session on this layer. You use the split tool to create a new polygon from a subdivision of an existing polygon. The old polygon continues to label fine but the new one is displaying no label and also no 'unplaced' label. 

Unless I've missed something I think this is a bug in ArcMap. Could you log it with tech support so the issue can be looked at?

Regards,

-Sam

0 Kudos
meganbarron
New Contributor II

Thanks Sam. I have basically come to the same conclusion. There are no unplaced labels and all other features in this layer label properly. Thanks for replying! We did tell IT who coordinates with ESRI. ESRI is not always the best about responding, but it's been communicated at least.

0 Kudos