Error when running Classify Objects Using Deep Learning from Raster Analytics

492
3
Jump to solution
05-18-2021 07:57 AM
Labels (2)
Shingo-Ikeda
New Contributor III

I have created *.dlpk and published to the enterprise portal using the ArcGIS Python API. We have installed Deep Learning Library to Raster Analytics Server and from our Portal, I launched  Classify Objects Using Deep Learning. I executed the inference after I selected the published model and filled parameters. It displayed the process icon for a while and failed with a simple Failed message.   

I looked at the log in the Raster Analytics and it shows some error messages as below:

  • SEVERE: Error executing tool. ClassifyObjectsUsingDeepLearning Job ID: jbde8f26feb0048a28792dd42e225b746 : OutputCatalogPath failed. Error: <built-in method GetOutputCatalogPath of HostedGP object object at 0x0000029B60BDC060> returned NULL without setting an error ClassifyObjectsUsingDeepLearning failed. Failed to execute (ClassifyObjectsUsingDeepLearning).
  • WARNING: ClientCachingAllowed property not found.
  • WARNING: IgnoreCache property not found.

I have tested the model in my local server from Pro and it works. Does anyone know what is going on?

ShingoIkeda_0-1621349699234.png

 

Shingo Ikeda
Geospatial Data Scientist/Developer - Geographical Information Platform
Global Power Generation - Digital Satellite USA and Canada
0 Kudos
1 Solution

Accepted Solutions
DanWade
Esri Contributor

This behavior was resolved through an Esri Technical Support case. The published deep learning model execution fails with error "GetOutputCatalogPath". This behavior was determined to be with the ArcGIS Data Store's "pg_hba" file. This file was updated to include an entry for the Image Hosting Server, Raster Analytics Server as well as the GeoAnalytics Server.

ArcGIS Data Store command utility reference > allowconnection

View solution in original post

3 Replies
DanWade
Esri Contributor

This behavior was resolved through an Esri Technical Support case. The published deep learning model execution fails with error "GetOutputCatalogPath". This behavior was determined to be with the ArcGIS Data Store's "pg_hba" file. This file was updated to include an entry for the Image Hosting Server, Raster Analytics Server as well as the GeoAnalytics Server.

ArcGIS Data Store command utility reference > allowconnection

InfodimGIS
New Contributor II

Have you resolved the issue for earlier versions of Image Server?
I try to run the detect_objects command in a ArcGIS Image Server 10.8.1 and It shows me the same or a similar error.

InfodimGIS_0-1651581561881.png

 



0 Kudos
Shingo-Ikeda
New Contributor III

I believe the resolution was included at 10.8.3 or a newer release, but not in the older version. 

Shingo Ikeda
Geospatial Data Scientist/Developer - Geographical Information Platform
Global Power Generation - Digital Satellite USA and Canada