Comminication flow between WebAdaptor y Server GIS

4116
1
04-19-2015 08:52 AM
SergioAlarcon_Ortega
New Contributor II

​hello everybody

I have 2 servers with webadaptar, wa1 and wa2, and 2 GIS server, ags1 and ags2. Both GIS server share same confing directory. Between wa and ags are firewall

my gis gis server is 10.2.1

When I instaled, I registed wa1 with ags1 , and wa2 with Ags2,

I had to open firewall wa1 to ags1(6080) and wa2 to ags2(6080)

do you have to open firewall, wa1 to ags2(6080), and wa2 to ags1(6080)???

How do wa1 known ags2??

0 Kudos
1 Reply
MiguelMorgado
Occasional Contributor

Hi Sergio/Hola

I think exist a bit of confusion here.

gis1 and gis2 are your ags servers right?

and you have installed on these same servers the web adaptor. so for example you installed on server gis1 the web adaptor wa1? is that correct? because need to be like that anyway.

you need to open the port 6080 on server gis1 only if you intend to access the rest via the "normal" ags rest url:

something like http://gis1:6080/arcgis/rest/services

if you don't intend to use port 6080 no need to be open. you can use the web adaptor url which uses port 80:

http://gis1/wa/rest/services

wa is the webadaptor name you gave when installed the software/

In any case you will need a cluster (network alias) for the High availability to work. for example you can create microsoft network load balancer and create a alias called agscluster to point primarily to server gis1 and if the checks fails automatic point to gis2 server.

your ags address to use in arcgisdesktop and web applications will be something like:

http://agscluster/wa/rest/services

vary in mind you will need a second license for AGS to in HA how swap (second server always on and sharing load).

You can use same configuration just for cold failover using only one license if the second server is always off and not run any map services (cold failover)

have fun!

Miguel

0 Kudos