Support for Oracle 12.2 on 10.2.1 SDE application server.

871
7
Jump to solution
01-16-2020 05:50 AM
MartinKrál
Esri Contributor

Hi,

please, is there any support patch for 10.2.1 SDE application server to support Oracle 12.2?

There are patches for 10.2.1 Desktop and Server (when direct-connection  is used)

But is there similar patch for 10.2.1 SDE application server? I mean when those old-fashioned  "5151" connections are used?

Thanks

Regards

0 Kudos
1 Solution

Accepted Solutions
George_Thompson
Esri Frequent Contributor

I am going to say, probably not. This would be true since "ArcSDE Application Server" is no longer supported as of July 2019; Esri Support ArcMap 10.2 (10.2.1, 10.2.2) 

We also did not support Oracle 12.2.x.x at ArcGIS 10.2.2; System Requirements so that may cause some issues.

The ArcGIS 10.2.1 patches, lately, are specific to utilities.

--- George T.

View solution in original post

7 Replies
George_Thompson
Esri Frequent Contributor

I am going to say, probably not. This would be true since "ArcSDE Application Server" is no longer supported as of July 2019; Esri Support ArcMap 10.2 (10.2.1, 10.2.2) 

We also did not support Oracle 12.2.x.x at ArcGIS 10.2.2; System Requirements so that may cause some issues.

The ArcGIS 10.2.1 patches, lately, are specific to utilities.

--- George T.
MartinKrál
Esri Contributor

Thanks Thomas. I also suppose that it is not supported. I just wanted to be sure of it, and I could not found it in the Docs.

0 Kudos
George_Thompson
Esri Frequent Contributor

I would move away from the OLD sde application server and to direct connect only.

--- George T.
0 Kudos
MartinKrál
Esri Contributor

Originaly we were looking for some sort of workaround for our customer - SDE access for some pretty old applications that were built on 10.2.1 C/Java SDE SDK. I suppose that for those old apps there is no way how to connect to 10.2.1 SDE  in oracle 12.2 whatever connection type is used here.

Thanks.

0 Kudos
George_Thompson
Esri Frequent Contributor

You "may" be able to connect with direct connections, but the client was not tested/developed to work with Oracle 12.2.x.x

--- George T.
0 Kudos
MartinKrál
Esri Contributor

Unfortunately with DC same (same as with sde service start) error message:  db_get_dbms_release:: Invalid Release (12.2.0.1.0) Cannot determine DBMS release using dbms_utility.db_version function.   And tech support have just confirmed us, that there is no patch for old SDE server 10.2.1 to support Oracle 12.2, because SDE server was already at "mature support" when that support patch for 10.2.1 was released in 2018.So I think there is no way around it, except complete remake of those old apps. But thanks George anyway (and sorry for calling you Thomas)

0 Kudos
George_Thompson
Esri Frequent Contributor

No worries on the name. 

--- George T.
0 Kudos