Select to view content in your preferred language

Sharing a web layer fails with error 00231, despite the database already being registered as an ArcGIS Server data store

1558
5
02-21-2023 12:26 PM
mfcallahan
Occasional Contributor II

I have a PostgreSQL database instance running in the Azure Database for PostgreSQL service. I am able to successfully connect, create enterprise geodatabases within, and load feature classes. I am also able to register the database as a data store, both via ArcGIS Pro and ArcGIS Server Manager. However, when attempting to share a table in the database as a web layer (right click > Sharing > Share as web layer), it will ultimately fail with error 00231, "Layer's data source must be registered with the server." seemingly not recognizing the registered data store I had just added. I verified there were no typos or other configuration errors.

aom96Kc

 

Tech support provided the following guidance, which did not resolve the issue.

  • Remove previously registered data store

  • Open "Share as Web Layer" tool

  • Run "Analyze" and right click error 00231 > Register Data Source with Server

I observed something interesting at this point; the connection string automatically generated in the dialog box truncates the "@hostname" part of the username, and the validation will fail:

HfVeYVx

 

I am able to click "Import" in this dialog box and manually specify the .sde connection file, the generated connection string does not malform the username, and the data store can be registered. However, I am right back to the same issue and receive error 00231 once again when attempting to run "Share as Web Layer."

I'm hoping someone out there has observed this and found a workaround! 🤞

5 Replies
ChrisUnderwood
Esri Contributor

You haven't stated which Deployment Model you are using with your Azure Database for PostgreSQL. 

https://learn.microsoft.com/en-us/azure/postgresql/single-server/overview#deployment-models

PostgreSQL databases in Azure can be “Azure Database for PostgreSQL single server” or “Azure Database for PostgreSQL flexible server”. For Single server I would try using “username@database” style login, for flexible server I would try using just “username” style.

 

0 Kudos
mfcallahan
Occasional Contributor II

I am using the Single Server Azure Database for PostgreSQL deployment. I am also using the "username@hostname" credential - omitting the @hostname will not allow login on any client, Pro included. The issue here is that the connection string generated by ArcGIS Pro appears to be truncating the "@username"

0 Kudos
ChrisUnderwood
Esri Contributor

Are you using an up-to-date version of ArcGIS Pro, eg 2.9.7, or 3.0.4, or 3.1.0 ?

0 Kudos
mfcallahan
Occasional Contributor II

This issue is occurring in ArcGIS Pro 3.0.3, 3.0.4, and 3.1.0; ArcGIS Server version is 10.8.1. Esri has confirmed this is a bug (BUG-000156390). Pretty frustrating as it is claimed here that Microsoft Azure Database for PostgreSQL (Single Server option) is supported by Esri, but it doesn't appear to be fully so.

https://desktop.arcgis.com/en/system-requirements/latest/databases-in-the-cloud.htm

 

0 Kudos
ANH
by
New Contributor III

Hi @mfcallahan, did you manage to find a fix or workaround for this? I am currently experiencing the same problem.

0 Kudos