Geodatabase Diagrammer Error

4072
10
03-03-2016 07:35 PM
Highlighted
New Contributor

Hello,

I would like to know if anyone knows any solution to the problem I am facing. Basically, I have a geodatabase which I need to run in Geodatabase Diagrammer. I have a 10.3.1 version of ArcGIS and Visio 2013 (32-bit version). When I run Geodatabase diagrammer, this shows up (See attached pic).

Any help would be greatly appreciated.

regards,

Charlemagne Losaria

Reply
0 Kudos
10 Replies
Highlighted
New Contributor III

I am also having this same issue, although I am using 10.4.1.  Instead of a screenshot i just listed the text in the error message below.

Error: GeodatabaseDiagrammer.ViosoDiagram.OpenVisionDrawing(StraingfileName, String pathName) at GeodatabaseDiagrammer.ViosoDiagram.StartDiagram(String cPathName, String strVisioOutputFile) in C:\Temp\StudioAT\ArcGIS\RepositoryGitHub\GDBDiagrammer\SourceCode\Helpers\VisioDiagram.vb:line80 Msg: Could not load file or assembly 'Microsoft.Office.Interop.Visio, Version=15.0.0.0, Culter=neutral, PublicKey Token=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.

I love this tool and have relied on it for may years to discuss detailed GIS layer design options with non-GIS or non-technical staff. I have just upgraded my ArcGIS desktop to 10.4.1 Geodatabase Diagrammer version from github, and I have Visio Standard 2010. I have downloaded the 10.4.1 version. I have moved the stencils to the proper location and ensured that the paths are pointing to these locations, however I am still getting an error and am not sure what I am missing. I have also opened the templates and resaved them if prompted to the current version of Visio.  Please help, as I love this tool! Thanks in advance.

Reply
0 Kudos
Highlighted
MVP Regular Contributor
Reply
0 Kudos
Highlighted
New Contributor III

Thanks for the link.  This is where I downloaded the latest version of the Geodatabase Diagrammer from 10.4.x (I am on 10.4.1).  I will not be upgrading to 10.5 from some time and was hoping that I could get the 10.4 version working.  Were you able to get 10.4 working from this site?  If so, what version of Visio are you running because this might be where the issue is?  Thanks

Reply
0 Kudos
Highlighted
MVP Regular Contributor

I'm using Visio Professional 64-bit.

Works for both ArcGIS 10.4 and 10.4.1.

Reply
0 Kudos
Highlighted
New Contributor III

Thank you so much for the quick reply.  I am using Vision Standard 2010 and in this version I don't get the "File Block Settings" tab.  Did you installed the Geodatabase Diagrammer 10.5 and with ArcGIS Desktop 10.4.1 and have it work successfully?  If so, I'll install the 10.5 version and see if anything changes, but I still suspect it is with the missing tab where I am getting the issues.  I'm not sure if our corporation has a more recent license for Visio either.  Thanks again.

Reply
0 Kudos
Highlighted
MVP Regular Contributor

No, I did not test with the 10.5 version after that.

Post your issues as a question at : Issues · nicogis/Geodatabase-Diagrammer · GitHub 

Nico replies back with valuable suggestions there. Hope it helps!

Reply
0 Kudos
Highlighted
New Contributor III

Thanks, I have posted it there and hopefully get some help figuring out where the issue is.  Much appreciated and have a great long weekend.

Reply
0 Kudos
Highlighted
New Contributor

Hello Chris

I did you solve your problem? I'm with the same problem now...Can you help me, please?

I have Arcgis 10.5.1 installed and Visio 2010.

I'll be so grateful if someone could help...Thanks.

Aurete

Reply
0 Kudos
Highlighted