Utility Network Validate Topology Timeout

404
3
06-27-2019 01:47 PM
Highlighted
New Contributor

I am working on updating a Gas utility network and having some issues with validating topology.  I have split a very long (6 Miles long approx) pipe that connected to a large number of feeders.  The corresponding dirty area envelop is quite large and the density of features within that envelope is significant.  I have been unable to validate the topology because the GP Tool, Python, and the ArcGIS Pro UN Ribbon tool all timeout at approximately 10 minutes.  Has anyone come up with a work around / solution to a large network validation?  At this point I'm kind of stuck.  I turned up the the time a client can use the web service but that hasn't impacted the timeout on running the validation with the GP tool or Python. 

If I move to a smaller area outside of the large dirty are shown in the picture, make and edit / add a feature and validate the topology things work as expected.  To me, this indicates that the issue is probably related to the quantity of feature in the dirty area I've created.   

Any help appreciated!

Reply
0 Kudos
3 Replies
Highlighted
Occasional Contributor II

Hi Joe,

We are in the process of working on the performance of validate topology and anticipate having updates available with the ArcGIS Enterprise 10.8 release as well as through a patch to Enterprise 10.7 and possibly 10.7.1.  The fixes we are working on are related to running validate topology when there are existing errors within the extent being validated.

Have you created an incident with tech support?  If not, then you should do this as it might be necessary to get your data to ensure your issue is similar to ones we are already testing and working against.

Thanks, larry

Reply
0 Kudos
Highlighted
New Contributor

Hey Larry,

Thanks for the follow up, I did create an incident with tech support as well.  

Reply
0 Kudos
Highlighted
Occasional Contributor II

Was there ever a resolution to this.  I'm experiencing the same thing.  However I'm working in a very small area maybe 500x500 ft.

I'm on Enterprise 10.8.1 and Pro 2.6.3

Reply
0 Kudos