Time disappears when exporting from query

540
5
Jump to solution
07-06-2018 09:07 AM
AnnaAlligood
New Contributor

I am attempting to make a time-series in ArcGIS Online. I already have my four layers set up in ArcMap, and have successfully run time series on them all. The date fields are coded as dates and I've attached a screenshot for reference. The tables are made using Query Tables, as I have somewhere in the vicinity of 1500 records that needed matching to time stamps. Here's my problem - whenever I export the data to a shapefile, to fold it into a .zip for Online, the time stamps are shortened to just the date. Since all my data takes place on the same day, but at different times, I very much need those. Can anyone let me know what I am doing wrong? Why are my times disappearing when exporting? At first I thought it was a character # issue,  but shortening didn't help with anything.

Thanks in advance!!

Attribute table with all the time stamps

Attribute table after exporting

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
KenBuja
MVP Honored Contributor

Shapefiles Date fields can only hold date information, not time. From the documentation:

However, for coverages and shapefiles, the time portion is truncated from the datetime value. For example, the datetime 2002-08-20 12:00:00 PM is stored in a coverage or shapefile as 2002-08-20.

View solution in original post

5 Replies
KenBuja
MVP Honored Contributor

Shapefiles Date fields can only hold date information, not time. From the documentation:

However, for coverages and shapefiles, the time portion is truncated from the datetime value. For example, the datetime 2002-08-20 12:00:00 PM is stored in a coverage or shapefile as 2002-08-20.

AnnaAlligood
New Contributor

Thank you, that was a silly oversight!

I now have another problem - When importing, the time zone is wrong. I first did it in Pacific, then realized ArcGIS operates in UTC. I changed my time-enabled layer in ArcMap to UTC+adjusted for DST, but my time stamps are still off. Am I missing something? Not changing the right thing?

0 Kudos
KenBuja
MVP Honored Contributor

Are the features' time in UTC or Pacific? You should set them to the time zone they were recorded in. Otherwise, AGOL will assume they are UTC.

And don't forget to mark the question as answered.

0 Kudos
AnnaAlligood
New Contributor

They were recorded in pacific. 

Ive tried with both and both end up imported as the wrong time. 

0 Kudos
WilliamJameson
New Contributor

I guess I am dense, but restating the problem is not a solution. Referring to esri documentation about dates is also not a solution.

ArcGIS has dropped the ball on this. I have date-time in a CSV file. when converted to a shapefile the time is lost. I have over 375,000 records, so retyping anything is not an option. turns out too that converting my CSV file date-time column to text does not help either because arcMap sees that text column and identifies it as date and drops the time anyway. I cannot see a solution.

Why would anyone need 375,000+ records? ships crossing an ocean, or airplanes flying over a nation for two weeks are two reasons.

0 Kudos