simple export data fail

3708
7
02-04-2015 03:31 PM
PamMoore
New Contributor


I recently upgraded one machine to 10.2.2, and cannot get the export selected data from a feature class to work. As a quick fix, I tried to copy/paste the FC (in the same gdb) and got a failure there as well. There is no attr table generated, even when the export says it worked correctly. any idea's whats going on?

 

thanks

Tags (1)
0 Kudos
7 Replies
DanPatterson_Retired
MVP Esteemed Contributor

did you try to save it to disk rather than within the geodatabase?

0 Kudos
PamMoore
New Contributor

thanks for replying:

no, i have not, but none of the data I use is saved outside a geodatabase typically.  we don't use shapefiles as a rule, so that would not have occurred to me, nor would that be a workable solution.

i am not new at GIS, and this is most certainly a very simple task - one i have never had a problem with on any other version - so I'm just baffled!  its not a large dataset, one is a pointfile (23 points), one is a polyline (23 lines).  is there an issue with versioning between 10.1 and 10.2.2?

0 Kudos
PamMoore
New Contributor

OK - I tried selecting and exporting a few points from the original shapefile, and saving as a shapefile, and that DOES work.  This just adds to my confusion.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Then try a different geodatabase as your ouput

0 Kudos
KishorGhatage
Occasional Contributor III

1. Create  a new feature class  in Geodatabase

2. While creating geodatabase import the schema from the point feature class

3. Right click on the new feature class > Load > Load the data from point feature class.

Hope this is helpful

Kishor

JayantaPoddar
MVP Esteemed Contributor

Hi Pam,

Make sure you are not in feature editing mode while exporting/copying data.

Do a system reboot if the problem still persists.

Thanks,

Jay



Think Location
0 Kudos
RichardCourtney
New Contributor II

I will occasionally experience this problem too.  I find that once this happens the geodatabase will no longer accept exported features.  Saving outside the GDB works, but we want accurate feature geometry, so we want the exported features in the GDB.  I find that I can use the Import step to grab the exported shapefile and import it to the reluctant GDB.  It is an additional step, but I am able to maintain a single GDB and also accurate feature geometry.

I'd like for this not to happen, but I am at a loss as to why this occurs.  A usual sign of impending failure is that I select the features, go to Data/Export and Arc shows the path to the GDB, but offers me a shapefile extension.  That means the GDB has become closed to exported features.