Seeing 9.4 Database in 9.3.1? umm... no.

528
3
01-06-2010 11:42 AM
MicahWilliamson
Occasional Contributor II
I could not connect to my 9.4 Personal SDE from a 9.3.1 install. I can accept this. However it is very unfortunate that I cannot use or even see into a 9.4 File geodatabase in 9.3.1. is there a patch or tool to downgrade? (other than Shapefiles)
0 Kudos
3 Replies
TedCronin
MVP Honored Contributor
The geodatabase is going through major changes structurally as to why this is no longer supported.  There are a few threads discussing this change in course from ESRI.  The GDB tables themselves are being reduced to 6 tables thus they will not work when accessing a GDB from a past release.  It sounds like you are hoping for a Save A Copy function to be built into ArcMap, like what can be done with MXDs.
0 Kudos
RussellBrennan
Esri Contributor
Micah,

There is a geoprocessing tool 'Create File GDB' which will allow you to create an empty geodatabase at version 9.4, 9.3 or 9.2. After using this tool you could then use ArcGIS Desktop 9.4 to copy data from a 9.4 File Geodatabase to a 9.3 or 9.2 File Geodatabase which would enable you to view data in previous ArcGIS Desktop versions.

Edit:
This functionality will be available at Bata 2.
0 Kudos
MicahWilliamson
Occasional Contributor II
Gents,
Thanks for the answers. I will wait till beta 2 then.
0 Kudos