Save alias on GlobalID field

163
2
Jump to solution
07-12-2019 06:34 AM
MollyFoley
Regular Contributor

I am wondering if this is possible because every time I change the alias of the GlobalID field and then remove the layer and re-add it to the map, the field becomes GloablID again. Is there really no way to save it? GlobalID is just so non-descriptive when you're trying to use it in related tables. It doesn't make it obvious that GlobalID is the _NameHere_ID in the other feature class.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
JoeBorgione
MVP Esteemed Contributor

If you change the alias at the database level rather than when you add the layer itself, it should stick.  Here I've done it in ArcCatalog:

And it displays as such in ArcMap:

However I did the same sort of procedure in AcGIS Pro 2.4, where I changed the alias value in the Fields view and then saved the change; exited Pro and restarted a new project but when I added the same table, the Alias reverted back.....

Undaunted, I tried the Alter Field Tool available in Pro, but after several gyrations, I decided it was too early in the morning to spike my blood pressure by working in Pro. Perhaps you may have better luck with it...

That should just about do it....

View solution in original post

2 Replies
JoeBorgione
MVP Esteemed Contributor

If you change the alias at the database level rather than when you add the layer itself, it should stick.  Here I've done it in ArcCatalog:

And it displays as such in ArcMap:

However I did the same sort of procedure in AcGIS Pro 2.4, where I changed the alias value in the Fields view and then saved the change; exited Pro and restarted a new project but when I added the same table, the Alias reverted back.....

Undaunted, I tried the Alter Field Tool available in Pro, but after several gyrations, I decided it was too early in the morning to spike my blood pressure by working in Pro. Perhaps you may have better luck with it...

That should just about do it....
MollyFoley
Regular Contributor

In this case, thankfully, I am not using pro. Thanks, I'll try it out.

0 Kudos