Relationship Classes appear across all schemas

665
3
11-13-2013 01:36 PM
ChadMarch1
New Contributor III
I've got some relationship classes I created in one schema, but they appear across all schemas even though my schemas don't have general viewer access to the whole database. Anybody know why and what I can do to make sure they appear only in their schema or general viewer accounts?

ArcGIS 10.1 sp2, SQL Server 2012, Windows Server 2012
0 Kudos
3 Replies
AsrujitSengupta
Regular Contributor III
Chad,

The behavior you are observing is by design.

The below article mentions Feature Datasets, but that seems to be true for Relationship classes as well:
http://support.esri.com/es/knowledgebase/techarticles/detail/22721

You can have a look at the below scripts though:
�?� http://arcscripts.esri.com/details.asp?dbid=13428
�?� http://arcscripts.esri.com/details.asp?dbid=13886

Regards,
0 Kudos
MarcoBoeringa
MVP Regular Contributor
You can have a look at the below scripts though:
�?� http://arcscripts.esri.com/details.asp?dbid=13428
�?� http://arcscripts.esri.com/details.asp?dbid=13886


It is doubtful if these tools will work in 10.x, since they were designed for 9.x, and the geodatabase system tables underwent major changes from 9.x to 10.x (conversion to XML based), most likely rendering the suggested solutions useless.
0 Kudos
AsrujitSengupta
Regular Contributor III
Marco,

I didn't give those links as solution/workaround for the behavior...those are just for reference..

Regards,
0 Kudos