problem with address matching statistics window

308
1
08-29-2011 10:22 AM
Juliehordowick
New Contributor
Hello there,

I am doing some geocoding on the addresses of our program participants.  I have about 25000 addresses that I am running in batches of 2500 (anything more than that seems to crash the program before the matching is done). 

when I run the geocoding addresses function, it produces the geocoded shapefile and attribute table but the window that pops up when it is done, the one with the matching statistics that allows you to match interactively is not giving correct results.  It always says zero for the % matched, % unmatched, %tied etc.  Yet, if you look in the attribute table, most of the addresses have been correctly matched.  I am able to match interactively by selecting the 'all addresses' criteria in the rematch criteria section but no matter how many addresses I manually rematch - the statistics never change! 

Any ideas why this might be happening? I am very new to geocoding so maybe I am missing something obvious??? When I've run smaller sized files (<1000) I have not had this problem.

any help is appreciated - cheers, Julie

Oh - I am running ArcMap 9.2 and the data is stored in a dbf file prior to bringing it into ArcMap.
Tags (2)
Reply
0 Kudos
1 Reply
JoeBorgione
MVP Esteemed Contributor
Hello there,

I am doing some geocoding on the addresses of our program participants.  I have about 25000 addresses that I am running in batches of 2500 (anything more than that seems to crash the program before the matching is done). 

when I run the geocoding addresses function, it produces the geocoded shapefile and attribute table but the window that pops up when it is done, the one with the matching statistics that allows you to match interactively is not giving correct results.  It always says zero for the % matched, % unmatched, %tied etc.  Yet, if you look in the attribute table, most of the addresses have been correctly matched.  I am able to match interactively by selecting the 'all addresses' criteria in the rematch criteria section but no matter how many addresses I manually rematch - the statistics never change! 

Any ideas why this might be happening? I am very new to geocoding so maybe I am missing something obvious??? When I've run smaller sized files (<1000) I have not had this problem.

any help is appreciated - cheers, Julie

Oh - I am running ArcMap 9.2 and the data is stored in a dbf file prior to bringing it into ArcMap.


The fact that the process bails out with more than 2500 records is a problem, and I wonder if it's a memory issue on your machine.  I routinely geocode 50,000 +- records without a problem, in 9.3.1 and was doing the same in 9.2 .

The rest of your described issues are very strange as well, but I guess I don't need to tell you that.  I wonder if something is fishy with the software and you need to reinstall?

Not much to go in, but I hope it helps even a little.
can't wait to retire....
Reply
0 Kudos