Linear referencing real-time road updating by clicking and dragging

3112
5
10-09-2014 01:34 AM
GregCarr-Hyde
New Contributor II

Hi,

 

I'm fairly new to linear referencing and have been trying out the training and knowledge base options for some time to familiarize myself with the workflows of this tool. However I'm looking to use the tool in another way and I keep finding that the tool is primarily driven by extensive data capture into tables first.

 

I have searched the help forums and other blog posts on here but did not find something quite in the same line as I'm looking for.

 

Broadly speaking the aim of the exercise is to create a WebGIS interface where users are able to click on the road center lines and drag to a point to automatically populate features about a stretch of road. The idea being that a user can trace the road from a point to another and then capture if the road is gravel or asphalt (for example) and possibly also the road condition. The accuracy of the extents are not too important it is more of an initial guide for the type and quality of the road. There would be overlapping fields for the road segment that is captured as some extents would have gravel that is poor quality and good quality on the same stretch.

 

Has anyone run a project like this previously? Is there a workflow for basically running linear referencing in reverse instead of driving the line events by the underlying data having the digitized data populate a road route event?

 

If anyone can advise further that would be great.

 

Thank you

 

Regards

Greg Carr-Hyde

0 Kudos
5 Replies
RiyasDeen
Regular Contributor

Hi Greg,

Never implemented something similar. But the quickest and easiest way I think of is using a geoprocessing service. ArcGIS Help 10.1

  1. Create a model with Locate features along route tool
  2. Append the located event results to your master event table
  3. Publish this model as geoprocessing service.
  4. Pass the line user draws along with attributes as input to this geoprocessing service from your web application

Hope this helps!

0 Kudos
GregCarr-Hyde
New Contributor II

Hi Riyas,

Thanks for the suggestion. I had though about a model but hadn't though of the locate features along route tool.

I'll give it a go and send feedback if it works.

Thanks again

Greg

0 Kudos
GregCarr-Hyde
New Contributor II

Hi Riyas,

I've been running the model and it partially works in the sense that it is able to create a route table but the append will not work.

The main thing though is that the model needs to have specific user input of clicking a start and end point for the data input not typing in distances. Do you have any suggestions to all for that?

Thanks

Greg

0 Kudos
RiyasDeen
Regular Contributor

Hi Greg,

Are you getting any error or warning when attempting append? did you double check to make sure if your event table created using locate feature along route and your master event table schema are same?

In your case,

  • you'll have to pass both the start and end point in same request
  • Locate feature along route for start and end point to create two event tables
  • validate if both the point's event have a common route ID (Join both the tables on route id with keep only matching records option)
  • If there is at least one row pick the route ID and chainages (the join would result in two chainage column one each for start and end),
  • append route ID and chainage to your master table.
  • If there are no rows after join, the points specified are not along same route, throw an error back
GregCarr-Hyde
New Contributor II

Hi Riyas,

Thank you for getting back to me. Originally the tool was giving a missing perimeters warning as the tool was creating an empty output and thus append would not run. I did also check the shemas but am running it as "no test" and have set the fields I want to append manually - so I don't think this is the issue.

I've modified the model with perimeters but now get a failed to execute model. This is most likely my error as I don't have extensive experience with model builder either. I've attached images of the current state of the model but I will try the steps you've mentioned and let you know.

Hope this helps explain a little more from my side.

Model_1.jpgModel_2.jpgModel_3.jpgModel_4.jpg

0 Kudos