Issues exporting a Mosaic Dataset.

323
2
12-06-2013 10:20 AM
New Contributor
Hoping someone can help me with my problem.  I was tasked with taking historic naip images for each county in Montana and making a seamless image for the entire state that can be used in another application to be clipped based on a user's input.

The images were .sid format and since the imagery overlapped county boundaries it needed to be clipped to the county boundary and then mosiaced together.

I have been able to clip the images and mosaic them together with no problem. The issue comes when trying to export the dataset to a single image, currently a tiff, so that the other application can use it for clipping.

The issue is that the exported image displays as all black but it has RGB values when you use the info tool to click around the image. It also has the issue of not maintain the true extent of the entire state. 

Anyone familiar with why this might be happening and what I can do to correct this issue. I tried this entire process on a smaller scale of 4 counties and it worked with no issues. This is done using 10.1.
Reply
0 Kudos
2 Replies
New Contributor III
...

I have been able to clip the images and mosaic them together with no problem. The issue comes when trying to export the dataset to a single image, currently a tiff, so that the other application can use it for clipping.

The issue is that the exported image displays as all black but it has RGB values when you use the info tool to click around the image. It also has the issue of not maintain the true extent of the entire state. 

...  This is done using 10.1.


Bern,

Pls refer to the discussion first at http://forums.arcgis.com/threads/85826-Exporting-rasters-as-a-batch-in-ArcMap?p=303823&viewfull=1#po...

Secondly, advisable to use 10.2 onto MD (more stable than 10.1, on the export functions).

Also ensure that 'noData' is NON (not 256) and the exported format is in IMG. (TIFF can be produced from IMG.)
Reply
0 Kudos
New Contributor III
Hi there. I have a different issue -- I have a referenced mosaic dataset with a number of functions applied.  Since it covers much of South America, I need to clip out a small portion as a flat raster file to send to someone.  When I view the mosaic and classify it in Arcmap 10.2, it looks great, just like I need it.  Now, I export my area using Data > Export Data > to a .tif file.  Usually, this works great for clipping rasters to an AOI.  However, when I do it now, it creates my new raster, but WITHOUT THE FUNCTIONS APPLIED.  Why is this happening?  Is there a better method?
Thank you!


True!

If the function-chain applied into regular MD 10.2.1 or earlier (you can treat it as imagery processing processes) and then a NEW referenced MD is derived from this MD, the referenced MD will show changes, including spectral (as your finding).

Personally, it could be bugs or limitations on referenced MD. Not sure if ESRI is aware of this issue before ...


++++++++

However, if the referenced MD is created /selected from a regular MD, which contain many �??pre-processed�?? images by ERDAS/ ENVI/ PCI (not through function-chain in MD), this NEW referenced MD will retain same quality as the original MD (see the attachment).

In fact, �??referenced�?? MD has many limitations, compared to regular MD. Please refer to the Help Documentation on Referenced MD for the details.
Reply
0 Kudos