Error when editing in a version

722
8
11-12-2013 08:29 AM
SamanthaEdwards
New Contributor II
A couple of our users are getting an error when they try to edit in a version: "Could not edit the data in the folder or database you selected"
They both have editor rights and have been able to create versions without problems before today.

Any thoughts on what may be causing this?

We are using ArcGIS Desktop 10.0, SP 5 and ArcSDE 10.0

Thanks,
S
0 Kudos
8 Replies
RobertBorchert
Frequent Contributor III
someone probably added a new feature or made some modifications

start off by assigning privileges to them again.

Also, right click on one of the  feature datasets in ArcCatalog that is giving the issue. 

Select Manage

4th and 5th options should be Register as Versioned and Unregister as Versioned.  If register as versioned is NOT grayed out then you need to register as versioned

This is also where you can check privileges

You will need to be logged in as the SDE administrator.
0 Kudos
SamanthaEdwards
New Contributor II
Thanks for the response...we did add some feature classes to 2 different datasets and we still have to reversion those datasets. I wouldn't think that would affect the whole database though just those datasets(i.e. you would get an error that the layer wasn't versioned when trying to edit), is that not the case? We will try reversioning and see if that works.

Thanks,
S
0 Kudos
RobertBorchert
Frequent Contributor III
You are correct in that it should only effect the feature datasets that were updated.  Unless someone accidentally unregistered the other feature datasets.




Thanks for the response...we did add some feature classes to 2 different datasets and we still have to reversion those datasets. I wouldn't think that would affect the whole database though just those datasets(i.e. you would get an error that the layer wasn't versioned when trying to edit), is that not the case? We will try reversioning and see if that works.

Thanks,
S
0 Kudos
SamanthaEdwards
New Contributor II
hmm..yea these users aren't able to edit any layers, even those in datasets that have not been modified.
0 Kudos
RobertBorchert
Frequent Contributor III
did you check their privileges?
0 Kudos
SamanthaEdwards
New Contributor II
It does have something to do with their privileges; myself and the other database admins are having no issues with editing and another user who does not have editing rights to the datasets that have been modified can still edit fine. It's only the users who have specific rights to the modified databases that are having issues. We will try to reversion the datasets this afternoon and hopefully that will be the fix. I'll let you know if it works.

Thanks for your help.

S
0 Kudos
SamanthaEdwards
New Contributor II
The datasets have been versioned and the users are still getting the errors. Their privileges have been double checked and reapplied. I am able to make the connection on my computer using their credentials and I do not get the error when trying to edit in a version.
0 Kudos
SamanthaEdwards
New Contributor II
Okay, I finally figured out the problem. Permissions had to be granted on the individual feature classes that had been added. Once this was done the users were able to edit. It still does not explain why layers outside of these datasets were not editable but at least the issue is solved.
0 Kudos