Can't create new geodatabase on database server

3508
3
10-17-2012 07:20 AM
Highlighted
Occasional Contributor III
I can't create a new geodatabase on a database server. When attempting to create the new geodatabase, the new geodatabase appears to be created and shows up in the ArcCatalog contents pane. However, when I attempt to connect to the geodatabase in ArcCatalog, I get the following error:

[INDENT]Failed to connect to database.
Bad login user.[/INDENT]

When I refresh ArcCatalog, the geodatabase no longer appears in the ArcCatalog contents pane.

Looking at SQL Server Manager, the new geodatabase does not appear in the list of databases. The log file doesn't give any indication of an error in creating the database (see attached -- error is when attempting to connect to the database that doesn't exist).

Using ArcGIS for Server 10.1 on Windows Server 2012 with SQL Server Express 2012.

Ideas on what's happening?

Thanks,

Jon.
Reply
0 Kudos
3 Replies
Highlighted
Esri Esteemed Contributor
Are you trying to make an *enterprise* ArcSDE geodatabase in SQL-Server Express 2012
(supported, with limitations) or a workgroup geodatabase?  Generally Esri only supports
the Express release that ships with ArcGIS.

- V
Reply
0 Kudos
Highlighted
Occasional Contributor
Jonathan,

We had the exact same problem when working with SDE for WorkGroup.  It was as though the database created, but it really didn't.

Tech support was called and immediately solved the problem.  There is a bug with a workaround.  It turns out that an item in the registry that indicates the ArcSDE_License was not written/created - it was totally missing.  Here is a copy of some of the email tech support sent regarding this (I spoke with them on the phone to solve this and she sent this follow up email).  We are using SDE for workgroup 10.1, SQL Express 2008 R2.  Slightly different OS and Express version so you may want to call tech support to see if the fix is the same since there are registry edits happening.   They responded very quickly to this one.

NIM083155: Under database servers if a GDB creation fails due to invalid license we need to refresh the TOC not to show the GDB entry, and provide a descriptive error message

Here is the Workaround for the bug:
1.  Download the ECP file from the following webpage:
    https://customers.esri.com/index.cfm?event=pub.ecpAuthorizations
2.  Open the ECP file with NotePad.
3.  Copy only the authorization for ArcSDE for SQL Server Workgroup 4.  Open the Windows Registry by typing "regedit". (No Quotes) 5.  Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSSQL$<SQL Express Instance> 6.  Right-click on MSSQL$<SQL Express Instance> and hover over New.
7.  A side window will pop up, select String Value.
8.  Type "ArcSDE_License" for the Name (No Quotes) 9.  Right-click on the newly created ArcSDE_License and select Modify...
10. Within the "Value data:" window, paste the value you copied from the ECP file.
11. Return to ArcCatalog and create the geodatabase as normal.
Reply
0 Kudos
Highlighted
Occasional Contributor III
Jon,

Did you run the authorization portion of the setup wizard for ArcSDE for SQL Server, specifying an ArcGIS Server Workgroup license?  You shouldn't have to edit the registry directly.
Reply
0 Kudos