Black Edges on Rasters

3560
4
Jump to solution
01-28-2013 02:43 AM
by Anonymous User
Not applicable
Original User: GEOSTUV03

Hi there

I have recieved these Rasters and in ArcMap they show up with Black edges/borders.

I have to make a mosaic of them without these black edges/borders.

Is there a way in ArcMap to hide them og get rid of them easy or do I have to manually clip them away from raster to raster and finally mosaic them?

There is "map" coverage 100% but one "black edge/border" lay itself on top of the map (as seen in the mosaic).
Reply
0 Kudos
1 Solution

Accepted Solutions
Esri Esteemed Contributor
Hi Henrik,

When you mosaic the rasters together using the Mosaic to New Raster tool, specify MAXIMUM for the Mosaic Operator parameter.  The output cell value of the overlapping areas will be the maximum value of the  overlapping cells.  You may still have the black collar around the final output, but you can remove this using the symbology tab, or by using the Copy Raster tool and specifying 0 for the NoData Value parameter.

View solution in original post

Reply
0 Kudos
4 Replies
Frequent Contributor II
Henrick,

The border is probably null values being displayed as black. If right click on the layer and select properties, click on the display tab and you have the option to display NoData as no color. If this does not work identify the black area to see if it has a RGB value, if it does use the option display background value and set the values to no color.

Regards

Anthony
Reply
0 Kudos
by Anonymous User
Not applicable
Original User: GEOSTUV03

Henrick,

The border is probably null values being displayed as black. If right click on the layer and select properties, click on the display tab and you have the option to display NoData as no color. If this does not work identify the black area to see if it has a RGB value, if it does use the option display background value and set the values to no color.

Regards

Anthony


Hi Anthony

Yes this seem to work fine on each single layers, but when i mosaic them together, the black edges comes back ? (And it's RGB color value 0-0-0 theres is black...if i use NoData in display it also takes out some features color in the map)
Reply
0 Kudos
Esri Esteemed Contributor
Hi Henrik,

When you mosaic the rasters together using the Mosaic to New Raster tool, specify MAXIMUM for the Mosaic Operator parameter.  The output cell value of the overlapping areas will be the maximum value of the  overlapping cells.  You may still have the black collar around the final output, but you can remove this using the symbology tab, or by using the Copy Raster tool and specifying 0 for the NoData Value parameter.

View solution in original post

Reply
0 Kudos
by Anonymous User
Not applicable
Original User: GEOSTUV03

Hi Jake

That answer did a lot to it, thanks.
Reply
0 Kudos