Attribute Editor and Domains

169
2
07-12-2018 11:03 AM
Highlighted
New Contributor

I have notice a difference when editing a feature in the Attribute Editor window when a field has a domain Assigned and the feature is symbolized based on that field, You do not get a drop down list as you would expect, instead you get a new window with the Domain values in it  (Choose Symbol Class dialog box). 

Is there a way not to get this box and just have the drop down list but still have the Feature class symbolized by that field?

Reply
0 Kudos
2 Replies
Highlighted
Esri Contributor

The options for editing attributes in the attribute window change depending on the layer's symbology. Single Symbol uses a pull-down for domain values while unique symbol uses a button (ellipsis) that brings up a symbol selector.

The symbol selector shows what symbology is used for each value so that the editor makes sure they are picking the correct value. The drop down can still be accessed when editing directly in the attribute table.

Another workaround is to have two layers in the MXD pointing to the same feature class. One will be used for display purposes with unique symbology based on the field with the domain. Make sure this layer is not selectable to avoid accidental editing. The second layer will be for editing with single symbology to be able to access the domain drop down. 

Highlighted
New Contributor

I understand why this might be useful in some circumstances, but using the the Symbol Selector adds Extra Mouse Clicks and Movement, and Duplicating Layers just adds to a Map with many layers in it all ready. I would suggest a change, so that you have the option to choose if you want the Symbol Selector to Show or just the Drop down in the Attribute Window. 

Thanks for the Clarification

Reply
0 Kudos