arcpy and attribute alias

2480
1
Jump to solution
12-09-2015 05:12 AM
Highlighted
New Contributor II

Hi!

I use a python script to change attribute alias name in an SDE database (sql server).

It goes very well except for some particular attribute.

If my attribute name is "VOCATION" and my alias is going to be "Vocation", the alias is not change.

It look like a case not sensitive problem.

Any Idea?  I run the python script within FME (python caller).

I use arcpy.AlterField_management for changing alias.

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Regular Contributor II

I think you may need to log a support ticket to see if this is by design. I would assume that at the database level this information wouldn't be case sensitive and the tool would think that you're trying to name the field to what it's already named. To get around it you could just add an extra character to the field and then change it back to the original word in the case you're needing.

View solution in original post

Reply
0 Kudos
1 Reply
Highlighted
Regular Contributor II

I think you may need to log a support ticket to see if this is by design. I would assume that at the database level this information wouldn't be case sensitive and the tool would think that you're trying to name the field to what it's already named. To get around it you could just add an extra character to the field and then change it back to the original word in the case you're needing.

View solution in original post

Reply
0 Kudos