Select to view content in your preferred language

ArcGIS World Geocoding Service gives different results for the same dataset

1009
8
07-10-2023 08:27 AM
Labels (3)
RoderickPearson
New Contributor II

I am using ArcGIS World Geocoding Service to Geocode a CSV file of 64,036 addresses. I set the geocoding options to 

Minimum candidate score: 70

Minimum match score: 75

The results of the geocoding process had:

  • Matched: 63,453 addresses
  • Tied: 583 addresses

However, when I attempted to replicate the process and geocode the table again under the same parameters I received slightly different results. 

The results of second geocoding process had:

  • Matched: 63,359 addresses
  • Tied: 677 addresses

I am confused as to why I received two different results using ArcGIS World Geocoding Service when using the same dataset and geocoding parameters, I would greatly appreciate any help or insight as to why I received two different results for the process.

Thanks, Roderick

0 Kudos
8 Replies
ShanaBritt
Esri Regular Contributor

@RoderickPearson Which application were you using when you geocoded your table with the ArcGIS World Geocoding Service when  you encountered the inconsistent behavior?

 

-Shana

0 Kudos
RoderickPearson
New Contributor II

I was using ArcMap version 10.5 when I geocoded my table with the ArcGIS World Geocoding Service when I encountered this problem. I thought the issue was because I was using a slightly older version of ArcMap however I could not find any information on this problem for that version of ArcMap specifically.

0 Kudos
ShanaBritt
Esri Regular Contributor

Are you still using ArcMap 10.5 or are continuing to get the same inconsistent behavior when using the ArcGIS World Geocoding Service? Does your organization have plans to move to ArcGIS Pro?

-Shana

0 Kudos
RoderickPearson
New Contributor II

I am still using ArcMap 10.5 and when I attempt to geocode the table again I get the following results again. 

  • Matched: 63,359 addresses
  • Tied: 677 addresses

I am now consistently getting this result in ArcMap whenever I geocode the table of addresses again however, I am still unsure at to how I received the original results of: 

  • Matched: 63,453 addresses
  • Tied: 583 addresses

I checked the geocoding settings however I have kept them the same when I geocoded the table. So I'm not sure whether that is the reason why the results were slightly different. My University does provide access to ArcGIS Pro however, when I geocode the table the results I receive in ArcGIS Pro are also slightly different. 

0 Kudos
ShanaBritt
Esri Regular Contributor

Which version of ArcGIS Pro is used by your University? Are you saving the geocode result out to a shapefile or geodatabase? Are you saving the geocode results to your local machine or network location?

-Shana

0 Kudos
RoderickPearson
New Contributor II

Currently we are using ArcGIS Pro version 2.8 and I'm currently saving the geocode results as a shapefile to my local machine

0 Kudos
ShanaBritt
Esri Regular Contributor

Do you get the same behavior when you save the output to a file geodatabase?

0 Kudos
RoderickPearson
New Contributor II

Yes, even when I output the file to a geodatabase I still get different results for geocoding than what I originally got

0 Kudos