Select to view content in your preferred language

ArcGIS not displaying for large rasters

12922
9
02-24-2012 11:13 AM
DonaldCatanzaro
New Contributor III
Hi All,

I have some File GeoDatabase Raster Datasets that are rather large (30m for the US and all told they run ~70GB).  What is odd is that none of these maps display at scales smaller than about 1:200,000.  When I zoom in tighter than 1:211,086 the data show up but at 1:211,087 the data disappear.

I have built the statistics and pyramids but this does not seem to make a difference.  This post forums.arcgis.com/threads/23452-ArcGIS-10-not-Displaying-.IMG showed a similar issue but a different scale and with IMG files.

Do I have some setting in ArcGIS that is preventing my data from displaying ?

Thanks !
0 Kudos
9 Replies
curtvprice
MVP Esteemed Contributor
You may want to try some different renderers and see if they do any better. Issues like this are really good things to take to Esri support if you can -- because that's how NIM#'s (bugs) get logged -- and fixed.

What is your ArcGIS Desktop version and service pack?
0 Kudos
MichaelStead
Regular Contributor
Have you tried deleting statistics and pyramids? If something goes awry in these files you get weird behaviours like this. I have no experience with imagery files this size, but there may even be some limitations in these GDB file structures causing issues. If they were files you could just delete the *.rrd and *.ovr.....as it is I think you'll have to trust ArcCatalog.
0 Kudos
DonaldCatanzaro
New Contributor III
I am using ArcGIS 10.0 build 3200 SP2.  License- ArcEditor

You may want to try some different renderers and see if they do any better. Issues like this are really good things to take to Esri support if you can -- because that's how NIM#'s (bugs) get logged -- and fixed.

What is your ArcGIS Desktop version and service pack?
0 Kudos
DonaldCatanzaro
New Contributor III
Hi Mike,

In a file geodatabase, where does one find the pyramids and/or statistics to delete them ?  Also, I should mention that this is not imagery but instead plain old raster data.  One is a categorical map with only two categories, the other two are raster maps with continuous data in them.

PS - I do not have Micro$oft products on this computer so I can not open it with MS Access.

-Don

Have you tried deleting statistics and pyramids? If something goes awry in these files you get weird behaviours like this. I have no experience with imagery files this size, but there may even be some limitations in these GDB file structures causing issues. If they were files you could just delete the *.rrd and *.ovr.....as it is I think you'll have to trust ArcCatalog.
0 Kudos
MichaelStead
Regular Contributor
I have had similar issues with classified rasters where the resampling in the higher level pyramids got messed up somehow.  You can open ArcCatalog and browse inside the gdb to the raster then right click hit properties. In this dialouge you can go to statistics and from the drop down select Clean Statisitics, then Build Statistics. You can also go to Pyramids and just hit build pyramids, then go to the environmental settings and go to the Raster Storage section and uncheck Build Pyramids, then run the tool (you could probably run it from toolbox I guess)..... pretty intuitive eh?
Anyways, you might also want to mess around with these settings (Environmental Settings>Raster Storage>Levels and Sampling Technique) to find some way to get acceptable display and drawing speeds. You might go crazy waiting for massive rasters with no pyramids which might not ever draw. I think having values instead of NULL (say in the square extent of your raster outside your classified area) messes with the pyramid resampling. You could try using a mask in the environmental settings if this might be the case. Just so you know I have been building 4 levels of pyramids today on a 21 Gig Tif and it has taken all day.
0 Kudos
PatrickTaurman
Occasional Contributor III
To remove pyramids on a file geodatabase raster, open the Build Pyramids tool, click the Environments button, and expand Raster Storage.  For Pyramid levels enter 0, then run the tool.  This will delete any pyramids you have built.  Once this is done, you can re-build pyramids to see if this helps.  You could also try exporting out to a different raster format, and see if you experience the same problem.

Patrick
MollyWatson1
Occasional Contributor

I am having a similar issue in ArcGIS 10.5.1. I have a large raster dataset (aerial imagery 3 band - 741 GB) that is stored on our SDE environment. It has pyramids and statistics.  It will only render when the symbology is set to stretched. It will not render when set to RGB composite. It won't even render with RGB composite when zoomed in. I have tried changing all of the rendering symbology settings, tried changing the Raster Layer settings under ArcMap Options, and tried changing the settings using the Raster Analysis. When I clip a small section of the raster, the clipped raster displays using RGB composite. I have an ESRI ticket in and haven't made much progress with the technician. She has suggested I copy the raster to a file geodatabase, but I don't have enough room on my computer to do that. I'd probably need a brand new computer with no programs on it which is not possible. She also suggested recreating the raster as a mosaic dataset but that is also not an option. We have several years of aerial imagery rasters all saved on our SDE environment and I have to follow the parameters put in place by the GIS administrator (which is a raster dataset - not mosaic).  I'm hoping this forum can help me out since I'm not having any luck with the technician. Thanks! 

0 Kudos
RonnieRichards
Regular Contributor

We are having very similar problems with 10.5.1 + and what appears to be inconsistency and instability with the pyramids tool. Sometimes they are successful and other times not. Successful meaning the tool reports they are built only to get prompted the pyramids do not exist or simply not seeing anything at smaller scales. Other times we are presented with this warning and have never run into this before? "C2018_MOSAIC_BLOCK1:   The display area covers too many pixels at the current display resolution. Please zoom in or build pyramids." This is coming up with clicking on the raster layer and clicking "zoom to layer". 

Older software releases prior to 10.3 did not appear to have this problem with our past collections in File or SDE GDB. 

I am curious what settings are you using for pyramids? Applying any compression on them?

0 Kudos
MollyWatson1
Occasional Contributor

We ended up removing the pyramids and statistics and rebuilding. This fixed our issue. We used Bilinear for the pyrmaid resampling technique and LZ77 for the pyramid compression. We also made sure in the environment settings, the workspace was not set to our local "N" desktop drive. 

0 Kudos