ArcGIS 10 Error: no editable layers

28501
13
Jump to solution
03-23-2012 07:02 AM
RomainHerren
New Contributor
Hello, I work on a lot of data that is on a server for my job. Since I switched to ArcGIS 10, I have all the time the problem as in the attached picture.
I do not work with geodatabase, but with .shp on the server. When starting an editing session, I receive always the error message "no editable layers". I looked for solutions and read a lot on forums (like this thread http://forums.arcgis.com/threads/27600-no-editable-layers-and-can-t-edit-versioned...) and the only thing that seems working is to copy everything on the C drive. But that's not a real solution...
I did not have this problem with ArcGIS 9.3, and because I work in a company, it is important for us to have our data on a server!

Does anyone have a idea? Thank you!
[ATTACH=CONFIG]12952[/ATTACH]
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
RobCahalan
New Contributor III

I know this was posted a long time ago but....If anyone has this same problem, be sure the the Data Frame your feature classes are in is Active. I just spent 30 minutes trying to resolve the problem and realized I had the wrong data frame active.

View solution in original post

13 Replies
RhondaGlennon
Occasional Contributor III
If you double-click a message in that window, it will open a help topic that provides more information and a solution, when available.

Since you are working on a network location, make sure that you have write access to the directory and that no one else is using the data at the same time. Sometimes you will see the no editable layers error in conjunction with other messages that provide more detail about why you cannot edit. The message list appears to indicate (based on a translation guess) that the layers are in a basemap layer.
0 Kudos
RomainHerren
New Contributor
Thanks for your answer. I have allready opened those help topics, end tried the few solutions proposed. No one works... I also tried this http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//002700000007000000.htm without success.

I have also check with the network manager of my company, and I have no access restriction. I am the only one who works with those data, so there is no conflict.

The thing I do not understand, is that I never had this problem with ArcGIS 9.3 before. With the same data, same network, etc.
So I guess there is something with ArcGIS 10...
0 Kudos
RhondaGlennon
Occasional Contributor III
Well, when working with shapefiles, make sure you have write-access to the folder in which they are stored and all the individual files (such as .shp, .dbf, etc.) that make up the shapefile. The settings you mentioned for versioned and non-versioned editing do not apply to shapefiles; they are only used with ArcSDE geodatabases.

Also, try adding the shapefiles to a blank map document to see if there is something in the map that is causing this.
0 Kudos
RomainHerren
New Contributor
I've checked once again, I have write-access to the folder and all the individual files.

Adding the shapefiles to a blank map document doesn't change anything. As soon as I start the editing session comes the error.

If this error doesn't happen, the editing session opens but when I want to save my edits, an other error saying "empty geometry" comes...

Since this error does not occur when I work on a local drive but only on a network location, I wonder what has changed since ArcGIS 9.3.
0 Kudos
RhondaGlennon
Occasional Contributor III
It sounds like there could be a problem with the shapefiles themselves, but it is odd that it works in ArcGIS 9.3 but not in 10. You might try importing them into a geodatabase and see if editing is successful. Otherwise, ensure that your ArcGIS 10 is updated (service pack 4 is the current release) in case there were any software issues that have been addressed.

You should contact Esri Support or your local distributor, if outside the US, for better troubleshooting of your exact scenario and data and to enter a bug into the system, if needed.
0 Kudos
RomainHerren
New Contributor
Yeah, odd is the word

Thanks for your advices, I'll try and come back there to give the reason/solution. I hope!

ps: allready with SP4...
0 Kudos
RobCahalan
New Contributor III

I know this was posted a long time ago but....If anyone has this same problem, be sure the the Data Frame your feature classes are in is Active. I just spent 30 minutes trying to resolve the problem and realized I had the wrong data frame active.

View solution in original post

JosephRyan
New Contributor II

Ugh, thank you!!!! I was really starting to loose it, then I found your post. Phew!

0 Kudos
RhondaPerozzo
New Contributor II

Thanks!  This was my problem... the correct layer frame was not active! Whew!  Thanks again!

0 Kudos