Another Snap to Raster problem

2847
4
Jump to solution
02-16-2012 07:33 AM
GerickeCook
New Contributor III
Seems like I'm not the only one? I am trying to snap NLCD data (clipped to a state) to the state's DEM. Obviously I need to do some overlay analyses. At first I was using the snap to raster environment setting during clip and projection operations (from the toolbox), but snapping was not occurring. I tried the "copy raster" tool with snap environment suggestion by ESRI off another forum. No dice there. It's almost as if snapping is not being honored.  FYI, I am using the same projection and cell size.

Should I try another workflow (order of operations) for getting snapped raster layers clipped to state level? I need to figure this out soon. I need to ramp up to national level very soon, so I need to snap national NLCD to a national DEM as well. I really want to get this working before I work with national data.

**UPDATE**
Don't know why I didn't see this before. There is a logged bug with high severity: http://support.esri.com/en/bugs/nimbus/TklNMDYxNTA2 but the status was declined. The description mentioned the use of core raster tools with background geoprocessing turned on. I'll try turning off background geoprocessing and see what happens. Maybe that's why it was declined? If I find a solution, I'll post it.
0 Kudos
1 Solution

Accepted Solutions
GerickeCook
New Contributor III
Okay. I logged an incident with Tech Support and here is the solution:

The snap to raster environment will be honored if 1) you turn off background geoprocessing and 2) you don't load the raster as a layer into the tool dialog (i.e. the raster is in your contents window in ArcMap). In other words, it's better to run the tool from ArcCatalog, manually browse and load the layers into the tool dialog and make sure that background geoprocessing is turned off. The solution worked for me. Supposedly the fix will arrive in SP4.

Something else I've noticed... My raster tools are running much faster with background geoprocessing turned off.

[ATTACH=CONFIG]12031[/ATTACH]

View solution in original post

0 Kudos
4 Replies
GerickeCook
New Contributor III
Okay. I logged an incident with Tech Support and here is the solution:

The snap to raster environment will be honored if 1) you turn off background geoprocessing and 2) you don't load the raster as a layer into the tool dialog (i.e. the raster is in your contents window in ArcMap). In other words, it's better to run the tool from ArcCatalog, manually browse and load the layers into the tool dialog and make sure that background geoprocessing is turned off. The solution worked for me. Supposedly the fix will arrive in SP4.

Something else I've noticed... My raster tools are running much faster with background geoprocessing turned off.

[ATTACH=CONFIG]12031[/ATTACH]

View solution in original post

0 Kudos
AndyRitchie
Occasional Contributor
Thank you gerickecook!!!

This was driving me nuts. I tried every possible snap to raster setting and finally came to the forums. I didn't find your post until I googled  "site:forums.arcgis.com snap raster not working" and limited my results to the past year <sigh>.

turning off background geoprocessing worked for me, and I was able to do the processing from within ArcMap and get a snap. Unfortunately (for me) turning off background geoprocessing looks like it breaks the "overwrite geoprocessing outputs" option. When I try to run the tool and overwrite a dataset, I get two errors: (1) The table already exists, and (2) No spatial reference exists. Renaming the output worked fine (I was working with file geodatabase rasters).

Seems like this would be a big deal. hope it's fixed soon.
0 Kudos
JeffreySwain
Regular Contributor
The reason that the bug report was 'declined' was that it is no longer reproducible in the latest version. So to answer your question, it is fixed in the new release.
0 Kudos
MardiGullage
New Contributor
Thank you so much for this. Thought I was doing something wrong. All it took was to turn off the geoprocessing. Thanks again!
0 Kudos