SQL Server 2016 support for ArcGIS Desktop version 10.2.1

2848
1
10-19-2016 07:57 AM
Status: Open
Pradip_Chakraborty
New Contributor II

Microsoft SQL Server database requirements for ArcGIS 10.2.x, support currently only extends to Microsoft SQL Server 2014.

http://resources.arcgis.com/en/help/system-requirements/10.2/index.html#//015100000070000000

Can this be extended for Microsoft SQL Server 2016 ?

 

We in Scottish Water are using ArcGIS Desktop 10.2.1 as that has been proposed as the most stable utility version from ESRI. Scottish Water Management intend to use the latest updates from Microsoft and hence want to use the SQL Server 2016 version in their estate. But unfortunately that is not supported with ArcGIS Desktop 10.2.1. How can we get rid of this ?

Tags (1)
1 Comment
JariSiiskonen

On ArcGIS 10.4 Microsoft SQL Server database requirements for ArcGIS 10.4.x—Help | ArcGIS Desktop  there is a note:

**Microsoft SQL Server 2016 is supported at ArcGIS 10.4 and 10.4.1. The Microsoft ODBC Driver 13 for SQL Server is only supported by ArcGIS 10.4.1 clients. For connections from ArcGIS 10.4 clients, the Microsoft ODBC Driver 11 must be used.

but I quess that does not extend back to ArcGIS 10.2.1 as there is:

Microsoft SQL Server 2014 is supported at ArcGIS 10.2.1 and 10.2.2.

  • The Microsoft ODBC Driver 11 for SQL Server is not supported by ArcGIS 10.2.1 or 10.2.2 clients. The SQL Server 2012 native client must be used instead.

So it seems that the connection code has changed a lot between ArcGIS 10.2 and 10.4 versions.

(By the way, just noticed that Microsoft ODBC Driver 11 for SQL Server is not supported(can't install) on Windows Server 2016)