Sharing a Service to E: on AWS using ArcMAP

3521
5
09-18-2015 09:30 AM
ChuckBenton
Occasional Contributor

I've inherited a Map Server that's implemented on AWS using EC2.  ArcGIS Help mentions 'When you first create the cache, you'll write it to an EBS volume that's attached to your EC2 instance. This volume is attached at the time you build your site, and it's a good place to put the cache if the volume is large enough. If the volume is too small, you need to create and attach another volume and register a server cache directory on it.".  The original implementation did not follow this advice, and when I share the map as a service it is done on the C: drive.

I'm running through Remote Desktop and managing my data in ArcMap.  I'm adding parcel data to the Table of Contents, and then using "file->Share As->Service" which brings up a dialogue that includes connection to "arcgis on localhost_6080 (publisher)", which I assume to be the ArcGIS server located on C: within the EC2 Instance. 

I am now encountering space limitations and must move the cache to another drive.  I have set up an EBS volume and attached it to the EC2 instance as drive E:.  I'm now floundering trying to get ArcMap to share to this new volume/drive.  I know I need to register "a server cache directory" and do this relative to the output function of ArcMap.  However, I cannot seem to find guidance on what steps to take.

Any suggestions or help is most appreciated!  FYI, I'm a newbie to the AWS-ArcGIS environment, so I apologize if this is a simple or obvious question!!

Thanks!

Chuck

0 Kudos
5 Replies
TimothyMichael
Occasional Contributor II

Chuck,

Here is the relevant help topic on server directories.  The 'Adding a server directory' and 'Editing a server directory' subtopics should point you in the right direction:

About server directories—Documentation (10.3 and 10.3.1) | ArcGIS for Server

Once you have the new cache directory created and configured in Server, you can do the following to move the cache:

  1. Create a new map service in ArcGIS for Desktop.  In the 'Caching' section of the Service Editor, choose 'An existing cached map / image service' and choose the existing service.  This will import the settings for the new cached service from the old.  Also choose the option at the bottom for 'Build cache manually after the service is published'
  2. In the same dialog, go to Caching > Advanced Settings.  Here you will be able to choose the new cache folder that you have configured for the E:\ drive.
  3. Once the service has published, you should be able to copy the existing cache directories from C:\ to E:\.  Restart the service once they have copied and confirm the service is working correctly, and if so, delete the service using the C:\ cache location.

I have done these steps before successfully; copying the cache to the new location and updating the cache directory in the service settings might work as well...maybe try that before re-publishing the service and going through the steps above.  Good luck!

--Tim

ChuckBenton
Occasional Contributor

Tim,

Thanks, this is really helpful!  I'm still having an issue, but a lot closer now...

I created a directory->  E:\BV\arcgiscache.  I then added this as an output type directory using ArcGIS Server Manager.  I then load my .mxd in ArcMap, and Publish a Service, when then Service Editor screen comes up, the Cache Section does not have "An existing cached map /image service" as an option, but do have "Using tiles from a cache". In advanced settings, my new directory is not offered on the pulldown, only the existing C: directory.

I've done a reboot and that hasn't helped. I'm using ArcGIS 10.2.1.3497 for Desktop (banner and icon says ArcMap).  Any ideas?

0 Kudos
TimothyMichael
Occasional Contributor II

Chuck,

Yes, in the Service Editor change the 'Draw this map service' option from 'Dynamically from the data' to 'Using tiles from a cache'.  Once you do that, the settings under Cache Settings > Tiling Scheme will become available. 

When you added the new directory in Manager, you should have added it as Type > Cache, not Output.  This is probably why it's not an output option in your cache dialog.

--Tim

ChuckBenton
Occasional Contributor

Cache vs. Output... yes... TGIF!  That appears to have solved the problem, it will take a couple hours to process, but unless I check back, all is good!

Thanks for the super quick responses!

Chuck

0 Kudos
TimothyMichael
Occasional Contributor II

Great!  Hopefully it "Just Works" and you don't have any more issues.

--Tim

0 Kudos