When is Visual Studio 2015 support coming?

2963
2
Jump to solution
12-28-2015 11:39 AM
Highlighted
Regular Contributor

Next week it will be 2016, yet the ArcObjects SDK still does not support Visual Studio 2015. When will I be able to build a Server Object Extension with Visual Studio 2015?

1 Solution

Accepted Solutions
Highlighted
Esri Contributor

ArcObjects SDK for the Microsoft .NET Framework 10.3.1 was the last release of ArcObjects .NET to ship with support for the Microsoft .NET Framework 3.5 (.NET 2.0 Runtime). At 10.4, ArcObjects .NET will ship with .NET Framework 4.5.1 as the default. All developers consuming ArcObjects .NET are encouraged to begin moving existing .NET-based extensions to .NET Framework 4.5.1 in anticipation of this change. This includes both ArcGIS for Desktop and ArcGIS for Server extensions. ArcObjects .NET 10.4 will install Primary Interop Assemblies (PIAs) built against .NET SDK 4.0 , and all new extension development should be started on .NET Framework 4.5.1 or later. ArcObjects .NET 10.4 will support Microsoft Visual Studio 2013 (Note: It will support Visual Studio 2015 if this has been released prior to the 10.4 final.) ArcObjects .NET 10.4 will not be supporting Visual Studio 2012.

2015 Update to the Deprecated Features for ArcGIS document | Support Services Blog

View solution in original post

2 Replies
Highlighted
Esri Contributor

ArcObjects SDK for the Microsoft .NET Framework 10.3.1 was the last release of ArcObjects .NET to ship with support for the Microsoft .NET Framework 3.5 (.NET 2.0 Runtime). At 10.4, ArcObjects .NET will ship with .NET Framework 4.5.1 as the default. All developers consuming ArcObjects .NET are encouraged to begin moving existing .NET-based extensions to .NET Framework 4.5.1 in anticipation of this change. This includes both ArcGIS for Desktop and ArcGIS for Server extensions. ArcObjects .NET 10.4 will install Primary Interop Assemblies (PIAs) built against .NET SDK 4.0 , and all new extension development should be started on .NET Framework 4.5.1 or later. ArcObjects .NET 10.4 will support Microsoft Visual Studio 2013 (Note: It will support Visual Studio 2015 if this has been released prior to the 10.4 final.) ArcObjects .NET 10.4 will not be supporting Visual Studio 2012.

2015 Update to the Deprecated Features for ArcGIS document | Support Services Blog

View solution in original post

Highlighted
Regular Contributor

So if I understand correctly, the answer to my question is that Visual Studio 2015 will be supported at ArcGIS Desktop / Server version 10.4.

Thank you.

Reply
0 Kudos