Error 1001. InstallUtilLib.dll, unknown error

2728
1
07-09-2012 08:11 AM
Highlighted
New Contributor III
Here is my scenario: I am working on migrating a 931 extension to version 10. As per the ESRI link, I have made changes and the revised installer and it works fine. When we went for deployment, the user account that we used before (@931 level) comes back with an error. It throws this error: Error 1001. InstallUtilLib.dll, unknown error. With some accounts with higher privileges, it works fine. it seems like there is a permission issue and I want to know what I need to ask from our System admin to resolve this issue.    

http://help.arcgis.com/en/sdk/10.0/arcobjects_net/conceptualhelp/index.html#//0001000002pv000000

Thanks
Jay
Reply
0 Kudos
1 Reply
Highlighted
New Contributor III
have an application (extension) that works fine on Windows XP platform. When I run this application on Windows 7 it throws this error. I am not sure what is causing this. I was thinking that it could be due to the fact that .net framework is not installed but I can see all in there. Looking for any ideas to resolve this issue.

Note: this error comes up when I click on a combox box. How can i get past this message box and get to actual error.

Thanks Jay

See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box.

***** Exception Text ******* System.NullReferenceException: Object reference not set to an instance of an object. at MapExt_Net.HEI_Extensions.layout.frmLayout.DisplaySize() at MapExt_Net.HEI_Extensions.layout.frmLayout.cBLayoutExtent_SelectedIndexChanged(Object sender, EventArgs e) at System.Windows.Forms.ComboBox.OnSelectedIndexChanged(EventArgs e) at System.Windows.Forms.ComboBox.WmReflectCommand(Message& m) at System.Windows.Forms.ComboBox.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

[ATTACH=CONFIG]16040[/ATTACH]
Reply
0 Kudos