Button images with transparent background

250
2
Jump to solution
12-14-2021 07:54 AM
AbelPerez
Occasional Contributor II

I am creating a Pro add-in with custom buttons. I've taken the standard image AddInDesktop16.png and AddInDesktop32.png and created two new buttons with the same properties. When I add them as image sources the add-in shows nothing.

They are in the same folder and I cant see anything that is different between the two. Are there restrictions on the images that I should take into account?

 

0 Kudos
1 Solution

Accepted Solutions
GintautasKmieliauskas
Regular Contributor

Hi,

Your post is in the wrong thread. You need this: https://community.esri.com/t5/arcgis-pro-sdk/ct-p/arcgis-pro-sdk .

Check in Visual Studio file properties window "Build action" setting of AddInDesktop16.png. It must be set to "AddInContent"

View solution in original post

0 Kudos
2 Replies
GintautasKmieliauskas
Regular Contributor

Hi,

Your post is in the wrong thread. You need this: https://community.esri.com/t5/arcgis-pro-sdk/ct-p/arcgis-pro-sdk .

Check in Visual Studio file properties window "Build action" setting of AddInDesktop16.png. It must be set to "AddInContent"

0 Kudos
AbelPerez
Occasional Contributor II

Wow, something much simpler than I thought. Thanks for the heads up. I completely forgot about adding the image in the project itself and setting the property to "AddInContent". You saved my day!!!

I hadn't touched this project in a year and a half so am a bit rustty.

 

 

0 Kudos