ArcGIS 10.3 migration issue

5144
3
01-14-2015 07:49 AM
ChiragDanech
New Contributor

Hello Everyone,

I am migrating existing tools written in ArcGIS 10 to ArcGIS 10.3. I am getting stuck on one of the error ("The user must be table owner") throws by one command while it tries to delete the version using IVersion.Delete()  method.

That command basically reconcile and post changes from current map version to it's parent version and switch map to parent version and delete child version.

Same command works fine on ArcGIS 10.

On database side I have upgraded geodatabase to ArcGIS 10.3 and grant required permission.

Anybody has any clue why it's getting failed and what that error means?

Appreciate your response.

Reply
0 Kudos
3 Replies
AlexanderNohe1
Regular Contributor II

Are you still connecting to the database as the same user that you connected with in 10.0?

Reply
0 Kudos
ChiragDanech
New Contributor

Yes. Everything is same. It just project compiled against ArcObjects 10.3 libraries.

Reply
0 Kudos
PascalVezina
Occasional Contributor

Are you using SQL Server?

Have you upgraded your database from SQL Server 2005 to 2008 by any chance?

In SQL Server 2005, db_owner’s were allowed to be mapped as “dbo” using alias.

This is no longer possible in SQL Server 2008. Only the database owner is mapped to “dbo”.

https://www.mssqltips.com/sqlservertip/1675/security-issues-when-using-aliased-users-in-sql-server/

This might be why you are getting this error.

Reply
0 Kudos