... ambiguous in the namespace ... visual studio 2010

863
3
Jump to solution
09-10-2012 04:00 AM
AnikaMeyer
New Contributor
Dear all:
I am migrating from Arcgis 9.2 to Arcgis 10, programming in VB.Net and  the software Visual Studio 2010. Now I can't solve the error message:
... is ambiguous in the namespace ...

For example:

IRgbcolor is ambiguous in the namespace 'ESRI.ARCGIS.Display'
Rgbcolor is ambiguous in the namespace 'ESRI.ARCGIS.Display'
IFillsymbol is ambiguous in the namespace 'ESRI.ARCGIS.Display'

Do you know any solution?
Thank you very much in advance.
Anika
Reply
0 Kudos
1 Solution

Accepted Solutions
NeilClemmons
Regular Contributor III
Make sure your project(s) is referencing the ArcGIS 10 ESRI assemblies and no longer referencing the ArcGIS 9.2 ESRI assemblies.

View solution in original post

Reply
0 Kudos
3 Replies
AkhilParujanwala
New Contributor III
I think there may be 2 possible solutions.

1) Make sure you are referencing the namespace correctly at the top:
[PHP]
imports ESRI.ArcGIS.Display;
[/PHP]

In your code, you can simply use IRgbColor.


2) Or you can not have the imports statement and just put when you are creating a pointer to the class.
[PHP]
ESRI.ArcGIS.Display.IRgbColor
[/PHP]

Hope this helps.
Reply
0 Kudos
NeilClemmons
Regular Contributor III
Make sure your project(s) is referencing the ArcGIS 10 ESRI assemblies and no longer referencing the ArcGIS 9.2 ESRI assemblies.

View solution in original post

Reply
0 Kudos
AnikaMeyer
New Contributor
Sometimes it takes a time to solve a problem. Sorry for answering so late and thanks for giving me the correct hint.
In the solution explorer I turned to false the property "Specific version" for the diferent references  and now it works.
Thank you ver much.
Kind regards.
Anika
Reply
0 Kudos