Dissolve and summarized union giving different area calculations

191
5
07-22-2021 05:17 PM
Labels (3)
tnels16
New Contributor II

I am trying to get the area coverage of a layer in my map, and the two methods I've used to do so are producing different results.

I used dissolve to create one feature in the layer and get the SHAPE_Area off the attribute table, and then I unioned the layer and summed the areas from that result. The dissolve is giving me 654901660.917106 m^2, and the summed union is giving me 1316663489.162411 m^2. Everything is using the same projected coordinate system. Anybody know what is happening?? This is driving me crazy...

0 Kudos
5 Replies
DanPatterson
MVP Esteemed Contributor

are the polygons overlapping anywhere?


... sort of retired...
0 Kudos
tnels16
New Contributor II
There were before I did the dissolve and union, but I did that to get rid of them.
0 Kudos
DanPatterson
MVP Esteemed Contributor

How Union works—ArcGIS Pro | Documentation

Union (Analysis)—ArcGIS Pro | Documentation

you might want to run the Multipart to singlepart tool as well and use the AddGeometryAttributes tool to confirm shape area values.  Check the latter result against a polygon that had no overlaps or adjoining polygons to confirm the process


... sort of retired...
0 Kudos
tnels16
New Contributor II
At what step do you run that tool? There is already geometry added to the layers.
0 Kudos
tnels16
New Contributor II

The multipart to singlepart tool didn't seem to help, but I was able to identify some overlap in the union, and feel more confident that the dissolve tool is giving the correct area now. Thank you!

0 Kudos