ArcMap 10.4.1 Arc segment features display as line

808
10
05-23-2019 11:31 AM
BillJones
New Contributor II

When I try to create a feature using an arc segment, only if the arc is shallow, as soon as I finish the arc or type in a large radius, the arc displays as a line.  It is still an arc segment as it gives the option to change to a straight segment.  Why won't it display as an arc? If I edit the vertices it only allows me to make the arc so shallow, then it automatically snaps to the line segment midpoint.

0 Kudos
10 Replies
Scott_Harris
Esri Regular Contributor

Hi Bill,

So far, I'm not able to reproduce. Some questions:

  1. Are you able to provide a screenshot?
  2. Which curve tool are you using (Endpoint arc segment, arc segment, tangent curve segment)?
  3. Where is the data sourced from (Shapefile, File Geodatabase, SQL Server, etc)?
  4. What are your snapping settings?
  5. What coordinate system are you using?
    1. Is it using default values for XY tolerance and resolution?
  6. At what map scale are you editing at?

Thanks,

Scott

0 Kudos
BillJones
New Contributor II

Arc Display

Here is a screen shot of what I am encountering, if I make the arcs any shallower than shown they snap to the center line. The arc has a 20 ft long chord in the screenshot. Using endpoint arc segment. Data is in file geodatabase. Snap settings don't seem to matter, I have tried turning snapping off. This is setup in state plane coordinates. Scale is usually under 1:1000 as these are waterlines, just depends on the curve data as to what scale I am editing them at.

0 Kudos
Scott_Harris
Esri Regular Contributor

Hmm.. I'm still not reproducing in 10.4.1 after first creating a 20 ft line and then using the end point arc tool to create another line snapped on each end like you show here.

Have you tried to suspend snapping by holding the space bar while creating the line segments?

0 Kudos
BillJones
New Contributor II

This video is currently being processed. Please try again in a few minutes.
(view in My Videos)

Here is a screen capture - I create an arc with a radius that works, then create one that is shallow and turns into a line, then i edit the arc and you can see the point where it snaps to a straight line.

0 Kudos
Scott_Harris
Esri Regular Contributor

Hi Bill,

For some reason the video isn't available yet, it says it's currently encoding. Hopefully it will show up and I'll be able to understand what's going on.

-Scott

0 Kudos
BillJones
New Contributor II

lets try a avi

Scott_Harris
Esri Regular Contributor

Ok now I can see this video - thanks for posting it. I'm not seeing anything that stands out that would cause it. Are the lines part of a geometric network? have you tried adding the data to blank MXD? I'm assuming you already tried holding spacebar while editing to suspend snapping?

Please also consider reaching out to Esri Technical Support ( Esri Support Contact Support  ). They may be able to quickly solve this with you over a screenshare.

0 Kudos
BillJones
New Contributor II

No geometric network, tried spacebar. Data in blank MXD works fine, so it it definitely seems to be related to the MXD file itself.

0 Kudos
ScottHarris3
New Contributor

Good to hear there's a workaround. the only way I can think of to get to the bottom of the issue would be to iteratively change things about the problem MXD while testing. For example,  remove all layers, change data frame properties, change layer properties, etc.  

0 Kudos