ArcGIS Desktop Layout View graphics not exporting properly

1203
9
07-31-2019 07:55 AM
JeanetteHarlow1
New Contributor III

I am trying to create a table in Desktop - layout view.  I'm using the Insert - Object - Microsoft Excel Worksheet options.

I'm able to create a nice - crisp table of data just fine.  I would like to have each line alternate in a yellow highlight to make things easier to locate.  This works just fine when creating, and adding to my map.Layout view of alternating Yellow/White table lines.

The problem lies in trying to export the map to a printable format.  (For one reason or another, I can not print my map as a large poster straight from the .mxd.  However, I was able to print a small version, and the highlighting prints out just fine.)

When I save the layout image as a .jpeg, .png, or a .pdf, the table background (that I set in my excel spreadsheet as alternating lines of white and yellow) shows as transparent. 

I was able to set the background as white, to eliminate the transparency, by right clicking on the table, Properties - Frame - Background set as white.  However, I would like to keep the alternating yellow highlighting that I can assign in the Excel file, and that also appears on the layout view.

Any suggestions?

9 Replies
JimCousins
MVP Regular Contributor

Hi, Jeanette. 

 What happens if you insert it as a picture element (Device independent bitmap, or an enhanced metafile)?

Regards,

Jim

0 Kudos
JeanetteHarlow1
New Contributor III

Hi Jim,

I have attempted inserting an image of the table (.jpg, .png) as a workaround.  I do have inserted images on my map, and all colors/elements are properly represented when exporting the map.  However, the quality of the imported images become relatively more pixelated and chunky, which is why I was trying to use the method above with respect to the table.

0 Kudos
JimCousins
MVP Regular Contributor

Have you explored pasting as an enhanced metafile? I find that these are pretty clear.

0 Kudos
JeanetteHarlow1
New Contributor III

Hi Jim,

I have explored that option.  Usually I clip using the snip tool, and the options to save are limited and do not include .emf option.  Further, I have explored saving in excel itself and am not sure how to save the table as an .emf.  When I save the snipped item in Paint, there is also no .emf option. 

However, I can save a snip in Powerpoint as an .emf, but the ability to crop the image, or adjust the size of the slide, to only include the desired graphic is a very time consuming process, of which I have not been able to successfully perform as of yet.

0 Kudos
TheresaJehn-Dellaport
New Contributor

I have been having the same issue and have noticed that the problem is limited to the bottom portion of the map extent. When I move the same tables into the upper ~70-80% of the map extent then the table exports correctly. It is the bottom ~2 inches of my map extent (11x17 layout with approximately a 3 inch title block on the bottom, so 2 inches above said title block) that is giving me issues.

0 Kudos
DavidPike
MVP Frequent Contributor

Select your data in excel.then apply a white background to all the cells, then add your alternating colour scheme to the excel rows. Copy and paste the selected data into arcmap layout view.

0 Kudos
JamesDrumm2
New Contributor

Looks like this problem is still going on 2 years later.  I'm getting the same result.  Copy/paste a colored Excel table into Arcmap and it exports with a transparent background.  Other steps that I've tried:
1. Paste in, change the background color in Arcmap = same result
2. Insert via Insert Object = same result
3. In Excel past into a picture, copy paste that picture to Arcmap = same result
4. Draw a white box, paste over the white box = same result
5. Change almost every setting in the Export to pdf window = same result

I'm running out of ideas.  Has anyone solved this yet?

0 Kudos
GraceMcCowan312
New Contributor

This is the only way I've figure out how to insert it with color:

Select table in excel, go to file and click "Save as Adobe PDF". Under Conversion Range, select "Selection".

Convert this to a PDF and open the PDF in Adobe. Go to "Tools" then "Crop". Crop your table to where there is no white around it, it should only be the table. 

Save it out as a JPEG. In ArcMap, go to "Insert" then "Picture" and insert your JPEG that way. 

Knock on wood, but this worked for me. 

0 Kudos
KateDoughty1
New Contributor

This did not work for me, very poor resolution...And not conducive to data tables that may change.

0 Kudos