Why do I get a "wait" icon as each image loads in the Nexrad widget ? WAB 2.0

3100
5
06-16-2016 02:16 PM
RobertJenkins1
New Contributor III

in WAB 2.0,  as each image loads and unloads in the mosaic, I'm getting a 'wait" icon at the lower right wabQuestion.png.

This is a new "feature".in 2.0.  Anybody else seeing this behavior?

Tags (1)
0 Kudos
5 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Robert,

  This is by design as the widget is suppose to show busy when any layer in the map is updating.

RobertJenkins1
New Contributor III

That is disappointing. The refresh for the images (and that wait icon) interrupts other popup windows. We'll have to find another solution that plays well with others.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Robert,

  If you are not happy with this you can disable it in the MapManager.js file

Just find the _addDataLoadingOnMapUpdate function and comment out the lines indicated below:

_addDataLoadingOnMapUpdate: function(map) {
        // var loadHtml = '<div class="load-container">' +
        // '<div class="loader">Loading...</div>' +
        // '</div>';
        // var loadContainer = html.toDom(loadHtml);
        // html.place(loadContainer, map.root);
        // on(map, 'update-start', lang.hitch(this, function() {
        //  html.setStyle(loadContainer, 'display', '');
        // }));
        // on(map, 'update-end', lang.hitch(this, function() {
        //  html.setStyle(loadContainer, 'display', 'none');
        // }));
        // on(map, 'unload', lang.hitch(this, function() {
        //  html.destroy(loadContainer);
        //  loadContainer = null;
        //  this._destroyLoadingShelter();
        // }));
      },
KentuckyDGI
New Contributor II

Commenting out the function as suggested above does disable the refresh icon from displaying in the lower right corner, however, configured popups in the web map still disappear each time the WMS image in the NEXRAD Widget loads an image. Will have to study this issue a bit more . . .

0 Kudos
KentuckyDGI
New Contributor II

It appears that the NEXRAD Widget on our test server and the ISU Version both have an issue under WAB 2.0.1 as it relates to loading of WMS images and popups. If a users clicks on a map feature in order to retrieve information, the popup quickly flashes on and off. If you change the refresh interval in our widget from 1 second to 10 seconds, the popup stays up for about 10 seconds and flashes off. I suspect that it must be changes in the MapManager.js or the PopupManager.js made at 2.0.1 that are causing this issue. Not really sure where to look at this point. Thanks for any assistance or guidance that can be provided.

0 Kudos