Web AppBuilder: [INFO] server - No portal URL is set, redirect /webapp builder to /webappbuilder?action=setportalurl

6601
6
02-19-2015 05:40 AM
JoseSanchez
Occasional Contributor III

Hi all

I am running Web AppBuilder for developers locally

when I start it and I enter http://localhost:3344/webappbuilder or   http://my computer name:3344/webappbuilder

The command window shows the following error message:

Error: connect ETIMEDOUT

    at errnoException (net.js:904:11)

    at Object.afterConnect [as oncomplete] (net.js:895:19)

[2015-02-19 08:12:36.296] [INFO] server - No portal URL is set, redirect /webapp

builder to /webappbuilder?action=setportalurl

Also when I "Specify the URL to your organization or Portal for ArcGIS"

it shows the following error message:

[2015-02-19 08:38:33.793] [ERROR] proxy - proxy error { [Error: connect ETIMEDOU

T] code: 'ETIMEDOUT', errno: 'ETIMEDOUT', syscall: 'connect' }

Error: connect ETIMEDOUT

    at errnoException (net.js:904:11)

    at Object.afterConnect [as oncomplete] (net.js:895:19)

0 Kudos
6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Jose,

   The only two suggestions I have are:

  1. Tips and Observations for getting Web AppBuilder - Developer Edition Installed
  2. Call Tech Support.
0 Kudos
MarkusAdmin
New Contributor

Hi all,

I've got the same problem. are not helping for me.

The Tips and Observations for getting Web AppBuilder -  Developer Edition Installed

are not helping for me.Has anyone any other suggestions?

Thanks in advance

Markus

0 Kudos
joaquinfernandez
New Contributor III

Try google chrome, I had the same thing and change to chrome and got it to work.

JunshanLiu
Occasional Contributor III

It seems that your node server can't access the portalUrl you set. Do you have to use a proxy to access the portal url?

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

I'm adding this possible resolution in a few threads (and my blog) since I just spent about 3 weeks with tech support trying to figure out the constant redirect back to the page requesting my AGOL URL.  I hadn't fired up WAB for a few months, so not sure if happened at the July or Sept AGOL update (not related to the version of WAB) and most likely was something I did (maybe a new AGOL option I think I needed?). 

On the AGOL Security page, I had my ArcGIS Server machine listed in the "Allow Origins" dialog.  Once I deleted the Domain I had listed, all worked again.  Just another thing to check if the other suggestions do not work.  May need it in the future (CORS related) but right now, leaving it blank is what is required for us.

0 Kudos
AndrewValenski__IT_
Occasional Contributor III

Howdy!

Can you give this info? It'll help diagnose where things are awry:

  1. Are you trying to connect to your organization's ArcGIS Online page or your organization's Portal for ArcGIS site?
    1. What is the URL you are using as an input when you're setting the portal URL during the WAB Dev setup?
    2. Have you already added the WAB Dev edition application to your organization's content?
    3. Have you already set the allowed referrers for that item?
  2. What version of WAB Dev are you attempting to deploy?
0 Kudos